summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2018-03-07 14:34:40 +0100
committerAdrià Cereto-Massagué2018-03-07 14:34:40 +0100
commitd296016fa55c765cf5dec06b9132abd28ce980dc (patch)
treea055a8e19e5404ecdf06731e2215b8dc5b915444 /PKGBUILD
parent0a27bdededb098baea2db2f77bd18c3dad84cc25 (diff)
downloadaur-d296016fa55c765cf5dec06b9132abd28ce980dc.tar.gz
change to stable staging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14da1ff175c8..3df862742ff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Daniel Bermond < yahoo-com: danielbermond >
pkgname=wine-staging-vulkan-git
-pkgver=3.3.r0.ge09e1fd3+
-pkgrel=2
+_staging_ver=3.3
+pkgver=3.3+20180304.58661056ff
+pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (staging branch, git version) with Vulkan patches'
arch=('i686' 'x86_64')
url='https://www.wine-staging.com/'
@@ -82,7 +83,7 @@ optdepends=(
options=('staticlibs')
install="$pkgname".install
source=('wine-git'::'git+https://github.com/roderickc/wine-vulkan.git'
- "$pkgname"::'git+https://github.com/wine-staging/wine-staging.git'
+ "staging.tar.gz"::'https://github.com/wine-staging/wine-staging/archive/v3.3.tar.gz'
'harmony-fix.diff'
'30-win32-aliases.conf'
'wine-binfmt.conf')
@@ -116,6 +117,9 @@ else
fi
prepare() {
+ tar xvf staging.tar.gz
+ rm -rf $pkgname
+ mv wine-staging-* $pkgname
cd 'wine-git'
# restore the wine tree to its git origin state, without wine-staging patches
@@ -137,15 +141,8 @@ prepare() {
}
pkgver() {
- cd "$pkgname"
- local _staging_tag="$(git tag --sort='version:refname' | tail -n1 | sed 's/-/./g;s/^v//;s/\.rc/rc/')"
- local _staging_version="$(git describe --long --tags \
- | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;s/\.rc/rc/' \
- | sed "s/^latest.release/${_staging_tag}/")"
cd "${srcdir}/wine-git"
- local _wine_version="$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;s/\.rc/rc/')"
-
- printf '%s+%s' "$_staging_version" "$_wine_version"
+ echo $_staging_ver+$(git log -1 --format=%cd.%h --date=short|tr -d -)
}
build() {