summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhoffer.joshua2019-04-09 10:21:56 -0600
committerhoffer.joshua2019-04-09 10:21:56 -0600
commit4e2bd95e44e2241ef5be7742fbe0d78c2d2523ee (patch)
treedd5a41f7c531aebb4e83634366be9283d80aa2d9 /PKGBUILD
parent9f1851cfcf227da66954bebaa1d05a5589aa61d3 (diff)
downloadaur-4e2bd95e44e2241ef5be7742fbe0d78c2d2523ee.tar.gz
updated source to 4.2 branch and reverted pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27d8ecbc6fa8..49a9859604ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Conttributor: xiretza <xiretza+aur@gmail.com>
pkgname=wine-valve-git
-pkgver=3.16.20190307
+pkgver=4.2.r270.g06353f78c3
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (Valve version)'
arch=('i686' 'x86_64')
@@ -81,7 +81,7 @@ optdepends=(
)
options=('staticlibs')
install="$pkgname.install"
-source=("$pkgname::git+https://github.com/ValveSoftware/wine.git"
+source=("$pkgname::git+https://github.com/ValveSoftware/wine.git#branch=proton_4.2"
'30-win32-aliases.conf'
'wine-binfmt.conf')
@@ -100,10 +100,16 @@ else
replaces=('bin32-wine')
fi
+#pkgver() {
+# cd "$pkgname"
+# # cutting off 'wine-' prefix that presents in the git tag
+# echo 3.16.$(git log -1 --format="%cd" --date=short | sed 's|-||g')
+#}
+
pkgver() {
+# cd "$srcdir"
cd "$pkgname"
- # cutting off 'wine-' prefix that presents in the git tag
- echo 3.16.$(git log -1 --format="%cd" --date=short | sed 's|-||g')
+ git describe --always | sed 's/^wine-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$pkgname"