summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortiziodcaio2024-05-12 19:20:21 +0200
committertiziodcaio2024-05-12 19:20:21 +0200
commitb170064ebc48968f40de7791963c9780a21b3f36 (patch)
treee4c121f203a5b203ab825b44bbc4bc30c21dd411 /PKGBUILD
parent982646de8300f7b170fa64fffb190c551b0ef439 (diff)
downloadaur-b170064ebc48968f40de7791963c9780a21b3f36.tar.gz
Re-add stripping in a more moderate way.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d531e760f04b..1b0ab8d9ef07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname="wine-wow64"
pkgver=9.8
_pkgver="${pkgver/rc/-rc}"
-pkgrel=2
+pkgrel=3
pkgdesc="A compatibility layer for running Windows programs"
url="https://www.winehq.org"
license=(LGPL)
@@ -104,6 +104,10 @@ package() {
ln -sf /usr/bin/wine "$pkgdir"/usr/bin/wine64
+ # Strip Windows binaries
+ i686-w64-mingw32-strip --strip-debug "$pkgdir"/usr/lib32/wine/i386-windows/*.dll
+ x86_64-w64-mingw32-strip --strip-debug "$pkgdir"/usr/lib/wine/x86_64-windows/*.dll
+
# Font aliasing settings for Win32 applications
install -Dm644 "$srcdir"/30-win32-aliases.conf -t "$pkgdir"/usr/share/fontconfig/conf.avail/
install -d "$pkgdir"/usr/share/fontconfig/conf.default