summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoland2020-01-28 01:52:53 +0100
committerRoland2020-01-28 01:52:53 +0100
commit6691da7eca44327e76a6af457ec34f10d8212c10 (patch)
treeca4726f09d805b1a2c6e10c0bd7a6aafd5abcb47 /PKGBUILD
parent88e8e9c973b9651d24c73d5c686e323903b93c2f (diff)
downloadaur-6691da7eca44327e76a6af457ec34f10d8212c10.tar.gz
update to wine 5.0
- remove 'without' configure options, add optional packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 23 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a7491046ebe..465a2cc02b27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Roland <hr_01y@protonmail.com>
pkgname=wine-x64
-pkgver=4.21
+pkgver=5.0
pkgrel=1
pkgdesc="A compatibility layer for running Windows programs. This only configured with x64 support."
url="http://www.winehq.com"
@@ -14,10 +14,10 @@ license=(LGPL)
# pkgver is not allowed to contain hyphens
_pkgbasever=${pkgver/rc/-rc}
-source=(https://dl.winehq.org/wine/source/4.x/wine-$_pkgbasever.tar.xz{,.sign}
+source=(https://dl.winehq.org/wine/source/5.0/wine-$_pkgbasever.tar.xz{,.sign}
30-win32-aliases.conf)
-sha512sums=('f962e47577db2de4e74022b8d51e81e30a004f98b37d8eee5889334271f013123e3ff53e5ac1416c2dd93ec90bee8a2d300b3842c20124df99ef067ac5c72f53'
- '0cee3e00f70e5438de89a273d5b7148a19a976f038125f555c037eedd30a6063b60a90ad08b356a5ef7f4c20edadc2546e64fa5b1bbd19555034ee013f120971'
+sha512sums=('681de951804c3dd3ae8c677a0ea52d172b04cac58594698b191cd972b25899cd2030d01a25fc2ad2eb6b99976a30319d2bd5ba8b7ff98b1a8b43832fa6514b83'
+ 'fad666dc0a0906ff1724e8fe9c7cfecd9f654d83c00ebd0b745b2086d1452f08394dec8ea3bbacb5378b6c0b84caa306cb3e037bd83012ff27b9374a11487932'
'6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb')
validpgpkeys=(DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D)
@@ -33,13 +33,29 @@ depends=(
libxrandr
libxi
freetype2
+ libxinerama
+ libxcomposite
+ glu
)
makedepends=()
-optdepends=()
-
-makedepends=(${makedepends[@]} ${depends[@]})
+optdepends=(
+ v4l-utils
+ opencl-headers
+ opencl-icd-loader
+ libpulse
+ gsm
+ libgphoto2
+ sane
+ libcups
+ openal
+ faudio
+ mpg123
+ vkd3d
+ vulkan-icd-loader
+ vulkan-headers
+)
prepare() {
@@ -63,22 +79,9 @@ build() {
--libdir=/usr/lib \
--with-x \
--without-gstreamer \
- --without-capi \
--without-hal \
- --without-vkd3d \
- --without-vulkan \
- --without-opencl \
--without-oss \
- --without-faudio \
- --without-gsm \
- --without-pulse \
- --without-mpg123 \
- --without-sane \
- --without-gphoto \
--without-mingw \
- --without-openal \
- --without-cups \
- --without-v4l2 \
--enable-win64
make