summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPedroHLC2021-07-26 09:28:35 -0300
committerPedroHLC2021-07-26 09:28:35 -0300
commitdb44bf0bae7629b01514e4d6184cbf036f4fdebf (patch)
tree2b587ead3708410676e43c05fed9f067e3f782d0 /PKGBUILD
parenta42dde7faf0e3bd468a3d155fcb87fd9e0888eb7 (diff)
downloadaur-db44bf0bae7629b01514e4d6184cbf036f4fdebf.tar.gz
Apply @Janhouse suggestions, but different pkgver and add v3 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD97
1 files changed, 46 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aafaabdebf64..26f939b44e36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,61 @@
-# Maintainer: Tony Lambiris <tony@libpcap.net>
+# Contributor: Tony Lambiris <tony@libpcap.net>
+
+_basename=wineasio
+pkgname=${_basename}-git
+pkgver=r99
+pkgrel=1
+
+pkgdesc="ASIO driver implementation for Wine"
+url="https://github.com/wineasio/wineasio"
+arch=('i686' 'x86_64' 'x86_64_v3')
+license=('LGPL')
-pkgname=wineasio-git
-pkgver=r50.4b23797
-pkgrel=2
-pkgdesc='WineASIO provides an ASIO to JACK driver for WINE.'
-arch=('i686' 'x86_64')
-url='https://github.com/jhernberg/wineasio'
-license=(LGPL)
depends=('wine' 'jack')
depends_x86_64+=('lib32-jack')
-makedepends=('ed' 'steinberg-asio-sdk')
-makedepends_x86_64+=('gcc-multilib' 'mingw-w64-headers')
-conflicts=(wineasio)
-provides=(wineasio)
-install=wineasio.install
-source=("${pkgname}::git+https://github.com/jhernberg/wineasio"
- "unicode.h")
-sha256sums=('SKIP'
- 'a552e487cba95883a15db612ae646df5d502a39afd7c4805b4ca0b549cc2f522')
+makedepends_x86_64=('gcc-multilib')
+provides=('wineasio')
+conflicts=('wineasio')
-pkgver() {
- cd "$srcdir/$pkgname"
+source=(
+ "git+https://github.com/wineasio/wineasio.git"
+ "git+https://github.com/falkTX/rtaudio.git"
+)
+sha256sums=('SKIP' 'SKIP')
+install="$pkgname".install
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+pkgver() {
+ cd "$srcdir/${_basename}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$pkgname"
-
- cp /usr/include/steinberg-asio/asio.h asio.h
-
- mkdir -p wine
- cp "${srcdir}/unicode.h" wine/unicode.h
-
- if [[ "$CARCH" == x86_64 ]]; then
- cp asio.h asio.h.i686
- ./prepare_64bit_asio
- fi
+ cd "${_basename}"
+ git submodule init
+ git config submodule.rtaudio.url $srcdir/rtaudio
+ git submodule update
}
build() {
- cd "$srcdir/$pkgname"
-
- if [[ "$CARCH" == x86_64 ]]; then
- make -f Makefile64
- mv wineasio.dll.so wineasio.dll.so.x86_64
- cp asio.h.i686 asio.h
- make clean
- fi
-
- make
+ cd "${_basename}"
+
+ if [[ "$CARCH" == 'x86_64' ]] || [[ "$CARCH" == 'x86_64_v3' ]]; then
+ make 64
+ cd build64
+ winebuild -m64 --dll --fake-module -E ../wineasio.dll.spec asio.c.o main.c.o regsvr.c.o > wineasio.dll
+ cd ..
+ fi
+
+ make 32
+ cd build32
+ winebuild -m32 --dll --fake-module -E ../wineasio.dll.spec asio.c.o main.c.o regsvr.c.o > wineasio.dll
}
package() {
- cd "$srcdir/$pkgname"
-
- if [[ "$CARCH" == x86_64 ]]; then
- install -D -m755 wineasio.dll.so.x86_64 "$pkgdir"/usr/lib/wine/wineasio.dll.so
- install -D -m755 wineasio.dll.so "$pkgdir"/usr/lib32/wine/wineasio.dll.so
- else
- install -D -m755 wineasio.dll.so "$pkgdir"/usr/lib/wine/wineasio.dll.so
- fi
-
- install -D -m644 README "$pkgdir"/usr/share/"$pkgname"/README
+ cd "${_basename}"
+ if [[ "$CARCH" == 'x86_64' ]] || [[ "$CARCH" == 'x86_64_v3' ]]; then
+ install -D -m755 build64/wineasio.dll "$pkgdir"/usr/lib/wine/x86_64-windows/wineasio.dll
+ install -D -m755 build64/wineasio.dll.so "$pkgdir"/usr/lib/wine/x86_64-unix/wineasio.dll.so
+ fi
+ install -D -m755 build32/wineasio.dll "$pkgdir"/usr/lib32/wine/i386-windows/wineasio.dll
+ install -D -m755 build32/wineasio.dll.so "$pkgdir"/usr/lib32/wine/i386-unix/wineasio.dll.so
}