summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Liu2015-09-17 12:27:57 +1000
committerJonathan Liu2015-09-17 12:27:57 +1000
commitc6c2ce92c708fc73ead43bc186e0b0d9074f5f70 (patch)
tree47d070055a2e20da512ebbd8b7cb8727feaa4795 /PKGBUILD
downloadaur-c6c2ce92c708fc73ead43bc186e0b0d9074f5f70.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..928682a78167
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=winexe-git
+_gitname=winexe-waf
+pkgver=r234.b787d2a
+pkgrel=1
+pkgdesc="Remotely execute commands on Windows NT/2000/XP/2003 systems"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/winexe/"
+license=('GPL3')
+depends=('mingw-w64-gcc' 'smbclient')
+makedepends=('python2')
+provides=('winexe')
+conflicts=('winexe')
+options=('!buildflags')
+source=("git://git.code.sf.net/p/winexe/${_gitname}"
+ "samba4.patch")
+md5sums=('SKIP'
+ '09379f3349f9ebefe2d11b90222110ad')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_gitname}/source"
+ patch -Np2 -i "${srcdir}/samba4.patch"
+}
+
+build() {
+ cd "${_gitname}/source"
+ python2 waf configure build --prefix="${pkgdir}/usr" --samba-inc-dirs=/usr/include/samba-4.0 --samba-lib-dirs=/usr/lib/samba
+}
+
+package() {
+ cd "${_gitname}/source"
+ python2 waf install
+}
+
+# vim:set ts=2 sw=2 et: