summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2018-09-05 17:23:33 +0100
committerGrey Christoforo2018-09-05 17:23:33 +0100
commit86836fbb7b2ab421c05b59bd1285115b735efb24 (patch)
treec374117370affaefe2da577d00e8e2ce4b1d79f0 /PKGBUILD
parent60202fc3f941e8413acaa999bc121ca885df691e (diff)
downloadaur-86836fbb7b2ab421c05b59bd1285115b735efb24.tar.gz
add some patches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4650c4dbe85f..f6a8e3c59a63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wingide
_wingver=6.1.0
_wingrel=1
-_wing_patch_lvl=1 #bump this when adding a patch
+_wing_patch_lvl=2 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
@@ -11,7 +11,7 @@ url="http://www.wingware.com"
license=('custom')
arch=('x86_64')
-_wingpatch=("fix-pep8-6.1.0p1-all.tar" "fix-pep8-6.1.0p2-all.tar" "fix-pep8-env-6.1.0p3-all.tar")
+_wingpatch=("fix-pep8-6.1.0p1-all.tar" "fix-pep8-6.1.0p2-all.tar" "fix-pep8-env-6.1.0p3-all.tar" "remote-replace-all-6.1.0p4-all.tar" "fix-sys-exit-reporting-6.1.0p5-all.tar" "fix-pypath-expansion-6.1.0p6-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
@@ -20,7 +20,10 @@ options=(!strip !emptydirs)
md5sums=('b4e5b7f9ec4be77e5e9e7e249b737b69'
'f96618da2fe8a5d12e90e0027a6e23f8'
'45c443b9b1ef24be01139bb9e5610cfa'
- '0dca244c6e605d9b4e9cb9fa0eed5b96')
+ '0dca244c6e605d9b4e9cb9fa0eed5b96'
+ '55b2b6f8ba70e5ee4146c0ec6cdefbe9'
+ '5b26502347ddbd5d29f356389f848af3'
+ '3a32eb00924f43f30c22a270e756c56a')
install=${pkgname}.install