summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2017-01-09 15:08:48 +0000
committerGrey Christoforo2017-01-09 15:08:48 +0000
commit869c9578bec70e8a2ecdff922ef34e6270d91603 (patch)
treed11e7905a55ac738546db1bb4b294fbc8cd7027b /PKGBUILD
parent79358e3905697542feadb6c61701127d35d6109c (diff)
downloadaur-869c9578bec70e8a2ecdff922ef34e6270d91603.tar.gz
version bump to 6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 12 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fc9b022dfa1..7793c16792bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,33 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=wingide
-_wingver=5.1.12
+_wingver=6.0.0
_wingrel=1
-_wing_patch_lvl=4 #bump this when adding a patch
+_wing_patch_lvl=1 #bump this when adding a patch
pkgver=$_wingver.$_wingrel.$_wing_patch_lvl
pkgrel=1
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
license=('custom')
-arch=('i686' 'x86_64')
-[ "$CARCH" = 'i686' ] && _pkgarch=i386
-[ "$CARCH" = 'x86_64' ] && _pkgarch=x86_64
-_wingpatch_x86_64=("detect-bad-window-sizes-5.1.12p1-all.tar" "pyc3351-5.1.12p3-all.tar")
-_wingpatch_i686=("detect-bad-window-sizes-5.1.12p1-all.tar" "pyc3351-5.1.12p3-all.tar")
+arch=('x86_64')
+_wingpatch=("disable-remote-projects-6.0.0p1-all.tar")
_patch_url_prefix=http://wingware.com/pub/$pkgname/$_wingver/patches/
-if [[ ! -z "$_wingpatch_x86_64" ]]; then
- _wingpatch_x86_64=( "${_wingpatch_x86_64[@]/#/$_patch_url_prefix}" )
-fi
-if [[ ! -z "$_wingpatch_i686" ]]; then
- _wingpatch_i686=( "${_wingpatch_i686[@]/#/$_patch_url_prefix}" )
-fi
-source_x86_64=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.gz" ${_wingpatch_x86_64[*]})
-source_i686=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-i386-linux.tar.gz" ${_wingpatch_i686[*]})
+_wingpatch=( "${_wingpatch[@]/#/$_patch_url_prefix}" )
+source=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.bz2" ${_wingpatch[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
-md5sums_i686=('6d3e20447ea2b772e4da38bf02c81031'
- '19a4bb32566a523d1acc677c8456c938'
- 'e983a04ccf2572bbfc48e3131b6d4635')
-md5sums_x86_64=('52b7f26a71e2a1ea9cbb51ade7181825'
- '19a4bb32566a523d1acc677c8456c938'
- 'e983a04ccf2572bbfc48e3131b6d4635')
+md5sums=('68b0ebd0c3c75d749b9f30de472233b0'
+ '859eceb26db31dde5e2eb11839a65925')
+
install=${pkgname}.install
prepare() {
- cd "$srcdir/$pkgname-$_wingver-$_wingrel-$_pkgarch-linux"
+ cd "$srcdir/$pkgname-$_wingver-$_wingrel-x86_64-linux"
sed -i 's/python/python2/' wing-install.py
}
package() {
- cd "$srcdir/$pkgname-$_wingver-$_wingrel-$_pkgarch-linux"
+ cd "$srcdir/$pkgname-$_wingver-$_wingrel-x86_64-linux"
./wing-install.py \
--install-binary \
--winghome "${pkgdir}/opt/${pkgname}" \
@@ -65,3 +53,4 @@ package() {
# Install the LICENSE
install -D -m 644 "${pkgdir}/opt/${pkgname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+