summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2016-05-01 18:18:18 +0100
committerGrey Christoforo2016-05-01 18:18:18 +0100
commitde04a352cc8baafe62ffeae9d131ffa2c5b32560 (patch)
tree3a492c6562d1c0a8a543e44a86c62e4bb67e73f0 /PKGBUILD
parent2e2f1e68eabf9b0fdd9ef2369ad8ec743bc56cd1 (diff)
downloadaur-de04a352cc8baafe62ffeae9d131ffa2c5b32560.tar.gz
fix issue with handling of multiple patch files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95b48c0f01cd..52c6edbda246 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=wingide
_wingver=5.1.11
_wingrel=1
pkgver=$_wingver.$_wingrel
-pkgrel=1
+pkgrel=2
epoch=2 #bump this when adding a new patch
pkgdesc="Wing IDE Professional is the full-featured Python IDE for professional programmers."
url="http://www.wingware.com"
@@ -21,14 +21,16 @@ fi
if [[ ! -z "$_wingpatch_i686" ]]; then
_wingpatch_i686=( "${_wingpatch_i686[@]/#/$_patch_url_prefix}" )
fi
-source_x86_64=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.gz" $_wingpatch_x86_64)
-source_i686=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-i386-linux.tar.gz" $_wingpatch_i686)
+source_x86_64=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-x86_64-linux.tar.gz" ${_wingpatch_x86_64[*]})
+source_i686=("http://wingware.com/pub/$pkgname/$_wingver/$pkgname-$_wingver-$_wingrel-i386-linux.tar.gz" ${_wingpatch_i686[*]})
depends=('hicolor-icon-theme' 'libpng' 'python2' 'xdg-utils')
options=(!strip !emptydirs)
md5sums_i686=('392b8f3a0e2dcb69fd2d8316bd88b028'
- 'fd1b66865a42b27fd6344b71e747c654')
+ 'fd1b66865a42b27fd6344b71e747c654'
+ 'ec4937a0b3fc32f553d7ea9d65cf11d9')
md5sums_x86_64=('ddacf06b4cc9577b9b80cbbb79de2d32'
- 'fd1b66865a42b27fd6344b71e747c654')
+ 'fd1b66865a42b27fd6344b71e747c654'
+ 'ec4937a0b3fc32f553d7ea9d65cf11d9')
install=${pkgname}.install
prepare() {