summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarodseth2012-05-03 07:43:11 +0000
committerarodseth2012-05-03 07:43:11 +0000
commit0321c09ba3fe1c65035ab2501e604f49c347b442 (patch)
tree05bf39419b823dd316286b63335c30271e5b3899 /PKGBUILD
parent81f11aac8c2c11cf46b9e73f2fa12facda32484a (diff)
downloadaur-0321c09ba3fe1c65035ab2501e604f49c347b442.tar.gz
Trying out the branch that should work with the latest version of erlang
git-svn-id: file:///srv/repos/svn-community/svn@70249 9fca08f4-af9d-4005-b8df-a31f2cc04f65
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbd443548e69..3b865857254e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,31 +16,32 @@ optdepends=('povray: rendering support via POV-Ray')
# 'kerkythea: rendering support via Kerkythea'
replaces=('wings' 'wings-devel')
install=$pkgname.install
-source=("http://downloads.sourceforge.net/wings/$_pkgname-$pkgver.tar.bz2"
+source=("$pkgname-$pkgver.tar.gz::https://nodeload.github.com/dgud/wings/tarball/dgud/r15b-driver-compat"
"$pkgname"
"$pkgname.png::http://img299.imageshack.us/img299/2538/wingsiconblackshiningew5.png")
-sha256sums=('51aea431e18935e5634ea673caa945f586db2203855554d8dcab5e9545f2789a'
+sha256sums=('cbe917601b31b7d469c2f9ed0de1b016be86f14f9e757860990d9489a84585dd'
'46513cd05f8b6e778120af4a87b239c5250799c17b591592893d98cbf082359e'
'6658977cc3bc8db2c9358edf3a2d6cb6bb8084c9a1d96ca573a83dd4e8781f1a')
_genericname=('3D Modeler')
+_dirname='dgud-wings-4f3a3ff'
build() {
cd "$srcdir"
gendesk
setconf "$pkgname.desktop" Categories "Graphics;3DGraphics;"
- cd "$_pkgname-$pkgver"
+ cd "$_dirname"
export ESDL_PATH=$(echo /usr/lib/erlang/lib/esdl-*)
make
make lang
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_dirname"
mkdir -p "$pkgdir/usr/lib/$pkgname"
for subdir in ebin fonts patches plugins shaders textures; do
- cp -r "$srcdir/$_pkgname-$pkgver/$subdir/" "$pkgdir/usr/lib/$pkgname"
+ cp -r "$srcdir/$_dirname/$subdir/" "$pkgdir/usr/lib/$pkgname"
done
install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"