summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarodseth2013-03-16 18:46:24 +0000
committerSantiago Torres Arias2013-03-16 18:46:24 +0000
commit70de85ec12ce517c72ac51b29f267c00478aea99 (patch)
tree5251c2bb1cbb57a09ac965e073d17005a0e7fe26 /PKGBUILD
parent001b845ad895a14af46b86db7b9a6e2559feb485 (diff)
downloadaur-70de85ec12ce517c72ac51b29f267c00478aea99.tar.gz
Added _categories
git-svn-id: file:///srv/repos/svn-community/svn@86419 9fca08f4-af9d-4005-b8df-a31f2cc04f65
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1254cc6e3e91..bb977186fff2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,10 @@ optdepends=('povray: rendering support via POV-Ray')
install=$pkgname.install
options=('!emptydirs')
_genericname=('3D Modeler')
-# Using the i686-only binary release
-# Would prefer using a source release, if there is one that compiles
+_categories=('Graphics;3DGraphics;')
+
+# Using the i686-only binary release.
+# - Would prefer using a source release, if there is one that compiles.
source=("http://sourceforge.net/projects/$_pkgname/files/$_pkgname/$pkgver/$_pkgname-$pkgver-linux.bzip2.run.gz"
"$pkgname.png::http://img299.imageshack.us/img299/2538/wingsiconblackshiningew5.png")
sha256sums=('760e19fa4973ed0fc75057897135a8efa241e834b078fc05c28786672137b322'
@@ -29,9 +31,8 @@ fi
build() {
cd "$srcdir"
- gendesk
- setconf "$pkgname.desktop" Categories "Graphics;3DGraphics;"
+ gendesk
chmod +x "$_pkgname-$pkgver-linux.bzip2.run"
"./$_pkgname-$pkgver-linux.bzip2.run" --nox11 --nochown --tar xf > /dev/null
setconf install_wings INSTALL_DIR "$pkgdir/opt/$pkgname-$pkgver"
@@ -39,17 +40,16 @@ build() {
package() {
cd "$srcdir"
- ./install_wings
+ ./install_wings
cd "$pkgdir"
setconf "opt/$pkgname-$pkgver/$_pkgname" ROOTDIR "/opt/$pkgname-$pkgver"
install -Dm755 "opt/$pkgname-$pkgver/$_pkgname" "$pkgdir/usr/bin/$pkgname"
-
cd "$srcdir"
- install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$pkgname.desktop" \
"$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: