summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarodseth2018-08-22 13:32:16 +0000
committerSantiago Torres Arias2018-08-22 13:32:16 +0000
commit90149ad7b43fdc250b837e42132e4beb2ff15d20 (patch)
treec798dd61add413c3192d3cbdd7137786781b9cfe /PKGBUILD
parenta250c097065aaac8eb6ea5752fb02781fb5254bd (diff)
downloadaur-90149ad7b43fdc250b837e42132e4beb2ff15d20.tar.gz
upgpkg: wings3d 2.1.7-2
git-svn-id: file:///srv/repos/svn-community/svn@373249 9fca08f4-af9d-4005-b8df-a31f2cc04f65
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eff17313ad5e..bbd8baa3c780 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# $Id$
-# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
# Contributor: kappa <kappacurve@gmail.com>
pkgname=wings3d
pkgver=2.1.7
-pkgrel=1
+pkgrel=2
pkgdesc='3D modeling program'
arch=('x86_64')
url='http://www.wings3d.com/'
license=('GPL')
depends=('desktop-file-utils' 'erlang' 'erlang-cl' 'erlang-sdl')
makedepends=('gendesk' 'imagemagick')
-optdepends=('povray: rendering support via POV-Ray')
+optdepends=('povray: render scenes with POV-Ray')
source=("https://downloads.sourceforge.net/project/wings/wings/$pkgver/wings-$pkgver.tar.bz2"
"$pkgname.sh")
sha256sums=('c2f4787ac2f8c874cdbb57c87a3e267a54e7f7f90082c9885e96290d1102ff24'
@@ -26,20 +26,20 @@ prepare() {
--genericname '3D Modeler' \
--categories 'Graphics;3DGraphics'
- convert $_p/win32/wings.ico $pkgname.png
+ convert "$_p"/win32/wings.ico $pkgname.png
# Path fix for building wpc_lwo
- ln -s $_p $_p/plugins_src/import_export/wings
- ln -s $_p wings
+ ln -s "$_p" "$_p"/plugins_src/import_export/wings
+ ln -s "$_p" wings
- sed -i 's/-Werror//' $_p/{src,e3d,plugins_src/import_export}/Makefile
+ sed -i 's/-Werror//' "$_p"/{src,e3d,plugins_src/import_export}/Makefile
}
build() {
export ESDL_PATH="$(echo /usr/lib/erlang/lib/esdl-*)"
export ERL_LIBS="$srcdir"
- make -C $_p all lang
+ make -C "$_p" all lang
}
package() {
@@ -51,9 +51,9 @@ package() {
install -d "$pkgdir/usr/lib/$pkgname"
for subdir in e3d ebin icons plugins psd shaders src textures tools; do
- cp -r $_p/$subdir/ "$pkgdir/usr/lib/$pkgname"
+ cp -r "$_p"/$subdir/ "$pkgdir/usr/lib/$pkgname"
done
}
-# getver: wings3d.com/?page_id=84
+# getver: -u=2 github.com/dgud/wings/releases
# vim: ts=2 sw=2 et: