summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarodseth2013-03-03 23:55:45 +0000
committerSantiago Torres Arias2013-03-03 23:55:45 +0000
commita8dbbd592a120a6cfc3f86c220cd3e9a37be7520 (patch)
tree4f1c7da7219c3d7bee3a2f31b17fe7823d7ef2ee /PKGBUILD
parentadd180267ed779420f0f04f6e52b72630ca2b471 (diff)
downloadaur-a8dbbd592a120a6cfc3f86c220cd3e9a37be7520.tar.gz
upgpkg: wings3d 1.4.1-15.
sing the binary release instead, for now. git-svn-id: file:///srv/repos/svn-community/svn@85611 9fca08f4-af9d-4005-b8df-a31f2cc04f65
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d93910c64f15..647b9d5d115c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,16 +10,15 @@ pkgdesc='3D modeling program'
arch=('x86_64' 'i686')
url='http://www.wings3d.com/'
license=('GPL')
-depends=('erlang-sdl>=1.2-7' 'erlang-cl>=1.0-3' 'bash' 'desktop-file-utils' 'erlang')
+depends=('erlang' 'erlang-sdl' 'erlang-cl' 'bash' 'desktop-file-utils')
makedepends=('setconf' 'gendesk')
optdepends=('povray: rendering support via POV-Ray')
install=$pkgname.install
-#source=("http://sourceforge.net/projects/wings/files/wings/1.4.1/wings-1.4.1-linux.bzip2.run.gz"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/dgud/wings/archive/master.tar.gz"
- "$pkgname.sh"
+options=('!emptydirs')
+# Using the binary release, but would prefer using a source release, if there is one that compiles
+source=("http://sourceforge.net/projects/$_pkgname/files/$_pkgname/$pkgver/$_pkgname-$pkgver-linux.bzip2.run.gz"
"$pkgname.png::http://img299.imageshack.us/img299/2538/wingsiconblackshiningew5.png")
sha256sums=('760e19fa4973ed0fc75057897135a8efa241e834b078fc05c28786672137b322'
- '46513cd05f8b6e778120af4a87b239c5250799c17b591592893d98cbf082359e'
'6658977cc3bc8db2c9358edf3a2d6cb6bb8084c9a1d96ca573a83dd4e8781f1a')
_genericname=('3D Modeler')
@@ -28,28 +27,21 @@ build() {
gendesk
setconf "$pkgname.desktop" Categories "Graphics;3DGraphics;"
- #chmod +x "$_pkgname-$pkgver-linux.bzip2.run"
- #mkdir -p "$_pkgdir/usr/share/$pkgname"
- #./$_pkgname-$pkgver-linux.bzip2.run --nox11 --nochown --tar xvf
-
- cd "$_pkgname-master"
- export ESDL_PATH=$(echo /usr/lib/erlang/lib/esdl-*)
- make
- make lang
+ chmod +x "$_pkgname-$pkgver-linux.bzip2.run"
+ "./$_pkgname-$pkgver-linux.bzip2.run" --nox11 --nochown --tar xf > /dev/null
+ setconf install_wings INSTALL_DIR "$pkgdir/opt/$pkgname-$pkgver"
}
package() {
- cd "$srcdir/$_pkgname-master"
+ cd "$srcdir"
+ ./install_wings
- mkdir -p "$pkgdir/usr/lib/$pkgname"
- for subdir in ebin fonts patches plugins shaders textures; do
- cp -r "$srcdir/$_pkgname-master/$subdir/" "$pkgdir/usr/lib/$pkgname"
- done
-
- install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgdir"
+ setconf "opt/$pkgname-$pkgver/$_pkgname" ROOTDIR "/opt/$pkgname-$pkgver"
+ install -Dm755 "opt/$pkgname-$pkgver/$_pkgname" "$pkgdir/usr/bin/$pkgname"
cd "$srcdir"
- install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 license.terms "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$pkgname.desktop" \
"$pkgdir/usr/share/applications/$pkgname.desktop"