summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarodseth2018-11-28 09:32:05 +0000
committerSantiago Torres Arias2018-11-28 09:32:05 +0000
commitc55dccfcb424855fa2ffb325b9ff648fe15b6117 (patch)
treee9a58af6f1a45e0b56f060da2d53bff09ac12c14 /PKGBUILD
parente1e8376751dec3386931ef37c6cfa8e4c0cb2efc (diff)
downloadaur-c55dccfcb424855fa2ffb325b9ff648fe15b6117.tar.gz
upgpkg: wings3d 2.1.7-4
git-svn-id: file:///srv/repos/svn-community/svn@410410 9fca08f4-af9d-4005-b8df-a31f2cc04f65
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9145f89d0981..372db2a06442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wings3d
pkgver=2.1.7
-pkgrel=3
+pkgrel=4
pkgdesc='3D modeler using the winged edge data structure'
arch=('x86_64')
url='http://www.wings3d.com/'
@@ -12,8 +12,10 @@ depends=('erlang' 'erlang-cl' 'erlang-sdl')
makedepends=('gendesk' 'imagemagick')
optdepends=('povray: render scenes with POV-Ray')
source=("https://downloads.sourceforge.net/project/wings/wings/$pkgver/wings-$pkgver.tar.bz2"
+ "wayland.patch::https://github.com/dgud/wings/commit/db074161e.patch"
"$pkgname.sh")
sha256sums=('c2f4787ac2f8c874cdbb57c87a3e267a54e7f7f90082c9885e96290d1102ff24'
+ 'ab3da436b0f5be55b44569a7a9e7a2587981a0282ec380191cc75be97e7cb286'
'8e5e8f31d47ea55a0e9d311b7cc0eaac4e6050ac40506d3548b6ebae5d3618be')
_p=${pkgname%3d}-$pkgver
@@ -25,6 +27,7 @@ prepare() {
--genericname '3D Modeler' \
--categories 'Graphics;3DGraphics'
+ # Convert the icon in a reproducable way
convert +set date:create +set date:modify "$_p"/win32/wings.ico $pkgname.png
# Path fix for building wpc_lwo
@@ -32,6 +35,9 @@ prepare() {
ln -s "$_p" wings
sed -i 's/-Werror//' "$_p"/{src,e3d,plugins_src/import_export}/Makefile
+
+ # Make the 3D grid work with Wayland
+ patch -d "$_p" -p1 -i ../wayland.patch
}
build() {