summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Wu2017-11-07 16:36:23 +0000
committerPeter Wu2017-11-07 16:36:23 +0000
commit80d3a7ccb713b35098fc143e22b981ce7f9b2825 (patch)
tree209710702a73d4a47bccc2bb4df678e735a3df05 /PKGBUILD
parent5e16d47940c0c152e46ee4b118e20e55f8b1f62f (diff)
downloadaur-80d3a7ccb713b35098fc143e22b981ce7f9b2825.tar.gz
Fix LIBDIR and update libnghttp2 dependency
- Only the library is needed, not the full nghttp2 package. - Set the -DCMAKE_INSTALL_LIBDIR option to avoid filesystem conflicts.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f896592d1367..b527c6de78ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,7 @@
# Contributor: Daniel Nagy <danielnagy at gmx de>
pkgname=wireshark-git
-pkgver=2.3.0rc0+1510+gc274046
-pkgver=2.5.0rc0+667+gef24608db1
+pkgver=2.5.0rc0+1603+g0c1ea1cee1
pkgrel=1
pkgdesc="A free network protocol analyzer for Unix/Linux. GIT version"
arch=('i686' 'x86_64')
@@ -30,7 +29,7 @@ depends=(
'gnutls' # for SSL decryption using RSA keys
'krb5'
#'libsmi'
- 'nghttp2' # for HTTP/2 dissector
+ 'libnghttp2' # for HTTP/2 dissector
'sbc' # Bluetooth audio codec in RTP player
'snappy' 'lz4' # for cql dissector
'spandsp' # for G.722/G.726 codec support in RTP player
@@ -67,7 +66,9 @@ build() {
mkdir -p build
cd build
- cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ cmake .. -GNinja -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
ninja
}
@@ -80,4 +81,4 @@ package() {
chmod 754 "${pkgdir}/usr/bin/dumpcap"
}
-# vim:set ts=2 sw=2:
+# vim: ts=2 sw=2 et: