summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Wu2019-01-19 12:16:06 +0100
committerPeter Wu2019-01-19 12:16:06 +0100
commit9f323d483f2ecaff2c95c056eed412fc884d779b (patch)
treeb79bbee16f5c953f839efe9feafdab3ccb02b618 /PKGBUILD
parentf02c68da32335cbc7e8fe41c9e2e4f5eccd6c221 (diff)
downloadaur-9f323d483f2ecaff2c95c056eed412fc884d779b.tar.gz
Update dependencies, use group handling from the wireshark package
Rely on wireshark.sysusers (as is done by the wireshark package in the community repo) and change the install script to match. Remove final traces of GTK+.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e24ec94f164a..4c59f075b999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Daniel Nagy <danielnagy at gmx de>
pkgname=wireshark-git
-pkgver=2.5.1rc0+544+g1ac90d5254
+pkgver=2.9.1rc0+426+g5eb8edf1cb
pkgrel=1
pkgdesc="A free network protocol analyzer for Unix/Linux. GIT version"
arch=('i686' 'x86_64')
@@ -20,11 +20,8 @@ depends=(
'qt5-multimedia'
'qt5-tools'
'qt5-svg' # for SVG icons in the Qt GUI
- # wireshark-gtk (deprecated) depedencies
- #'portaudio'
- # shared between the GUI (for post-installation hook)
+ # for post-installation hook
'desktop-file-utils'
- 'hicolor-icon-theme'
# optional dependencies for improved dissection or features
'gnutls' # for SSL decryption using RSA keys
@@ -50,8 +47,10 @@ install=$pkgname.install
# clone --mirror", it pulls 830MB including all draft patches... As a
# workaround, use the Github mirror which should pull in "only" 424M.
#source=("git+https://code.wireshark.org/git/wireshark")
-source=("git+https://github.com/wireshark/wireshark")
-sha256sums=('SKIP')
+source=("git+https://github.com/wireshark/wireshark"
+ wireshark.sysusers)
+sha512sums=('SKIP'
+ '3956c1226e64f0ce4df463f80b55b15eed06ecd9b8703b3e8309d4236a6e1ca84e43007336f3987bc862d8a5e7cfcaaf6653125d2a34999a0f1357c52e7c4990')
pkgver() {
@@ -67,7 +66,8 @@ build() {
cmake .. -GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_BCG729=OFF
ninja
}
@@ -76,6 +76,7 @@ package() {
DESTDIR="${pkgdir}" ninja install
# GID for wireshark is 150
+ install -Dm644 "${srcdir}/wireshark.sysusers" "${pkgdir}/usr/lib/sysusers.d/wireshark.conf"
chgrp 150 "${pkgdir}/usr/bin/dumpcap"
chmod 754 "${pkgdir}/usr/bin/dumpcap"
}