summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Wu2016-11-08 18:27:30 +0100
committerPeter Wu2016-11-08 18:27:30 +0100
commitf1b5dd4fe20cf4a74c851376d0e8c5a46646c6da (patch)
tree8fecf60e545b5be03c694ae1f277501ff2e7c348 /PKGBUILD
parent9905e288cd17fe4e0284be95848ff0b6648bc316 (diff)
downloadaur-f1b5dd4fe20cf4a74c851376d0e8c5a46646c6da.tar.gz
Fix capabilities
Ensure that dumpcap is built with capabilities (currently implicitly pulled in via systemd). Prevent the world from having capabilities and add DAC privilege for usbmon support.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 005a23333e85..683b0c57b05a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,7 @@ depends=(
'c-ares'
'geoip'
'glib2'
+ 'libcap'
'libpcap'
'lua52'
@@ -74,6 +75,10 @@ build() {
package() {
cd "$srcdir/wireshark/build"
DESTDIR="${pkgdir}" ninja install
+
+ # GID for wireshark is 150
+ chgrp 150 "${pkgdir}/usr/bin/dumpcap"
+ chmod 754 "${pkgdir}/usr/bin/dumpcap"
}
# vim:set ts=2 sw=2: