summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBlair Bonnett2019-02-15 06:30:21 +0100
committerBlair Bonnett2019-02-15 06:30:21 +0100
commit0b408bc3ae12e857e5e018f2c9ef34c564214f91 (patch)
tree283698c4a2d7088e713868fdb12a9d0b1cf92df2 /PKGBUILD
parente6ecc368ae22afa1065ca6ac675ce66d9df512d8 (diff)
downloadaur-0b408bc3ae12e857e5e018f2c9ef34c564214f91.tar.gz
Patch in unreleased Python 3 and timeout support.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 17 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6372aaa349c..30c0241fa10f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,28 @@
pkgname=wispr
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simple command-line tool to authenticate against a WISPr server"
url="https://github.com/wichert/wispr"
arch=('any')
license=('custom')
depends=('python')
-source=('https://github.com/wichert/wispr/archive/release/1.0.tar.gz')
-sha256sums=('ba9994abee90d51c9d65fbb61241694a610a0198c5c4a833f8d7bf9c346ebd41')
+source=(
+ 'https://github.com/wichert/wispr/archive/release/1.0.tar.gz'
+ 'python3.patch'
+ 'timeout.patch'
+)
+sha256sums=(
+ 'ba9994abee90d51c9d65fbb61241694a610a0198c5c4a833f8d7bf9c346ebd41'
+ '7f14a07b35f7625b90163352ef943d225ef4ba01a5aa172e67174157e1b4b2cf'
+ '0cc5f11d022ff3c560f71ce7c7269dd55a50a31ba1ee9c230e0405801b777eb5'
+)
+
+prepare() {
+ cd "wispr-release-$pkgver"
+ patch -Np1 -i ../../python3.patch
+ patch -Np1 -i ../../timeout.patch
+}
build() {
cd "wispr-release-$pkgver"