summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Phillips2018-08-20 22:03:23 +1200
committerDavid Phillips2018-08-20 22:03:23 +1200
commit73b5c210b25aa17f2efdbc9418c7d0876cb405ff (patch)
treeae1e96d483a4181e64fc73f0c34ceb749cb4fd78 /PKGBUILD
parent53ff12fe2667fd02cd8db215c0b5f3cbd83819ef (diff)
downloadaur-73b5c210b25aa17f2efdbc9418c7d0876cb405ff.tar.gz
Bump to 0.12.5, use non-generic builds
Generic builds are no longer provided upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 13 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7d0ec2ca278..9e8ccaf33ef4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: dcelasun
# Maintainer : David Phillips <dbphillipsnz gmail dot com>
pkgname=wkhtmltopdf-static
-pkgver=0.12.4
+pkgver=0.12.5
pkgrel=1
pkgdesc="Shell utility to convert HTML to PDF using Webkit and Qt (upstream static build)"
arch=('i686' 'x86_64')
-url="http://wkhtmltopdf.org/"
+url="https://wkhtmltopdf.org/"
license=('GPL3')
conflicts=('wkhtmltopdf')
provides=("wkhtmltopdf=${pkgver}")
@@ -15,25 +16,20 @@ optdepends=('icu48: Rendering from HTML uses unicode character encoding')
# Debian packages are already stripped, so don't bother re-attempting
options=('!strip')
-source_x86_64=("https://github.com/wkhtmltopdf/wkhtmltopdf/releases/download/${pkgver}/wkhtmltox-${pkgver}_linux-generic-amd64.tar.xz")
-source_i686=("https://github.com/wkhtmltopdf/wkhtmltopdf/releases/download/${pkgver}/wkhtmltox-${pkgver}_linux-generic-i386.tar.xz")
-md5sums_i686=('ce1a2c0b2cf786ccc5d5828c42c99ddd')
-md5sums_x86_64=('96b7306cebb9e65355f69f7ab63df68b')
+source_x86_64=("https://github.com/wkhtmltopdf/wkhtmltopdf/releases/download/${pkgver}/wkhtmltox_${pkgver}-1.bionic_amd64.deb")
+source_i686=("https://github.com/wkhtmltopdf/wkhtmltopdf/releases/download/${pkgver}/wkhtmltox_${pkgver}-1.bionic_i386.deb")
+sha256sums_x86_64=('db48fa1a043309c4bfe8c8e0e38dc06c183f821599dd88d4e3cea47c5a5d4cd3')
+sha256sums_i686=('1f5ac84c1cb25e385b49b94a04807d60bf73da217bc6c9fe2cbd1f0a61d33f63')
package() {
+ tar -xJf data.tar.xz -C "${pkgdir}"
+
cd "${pkgdir}"
mkdir -p usr
- for dir in "${srcdir}/wkhtmltox/"* ; do
- mv "${dir}" usr/
- done
-
- #msg "Fixing permissions on:"
- #msg2 "Directories"
- #find ./ -type d -exec chmod -cR 755 "{}" \;
-
- # Non-bin and non-lib Files => rw-r--r--
- #msg2 "Files"
- #find ./usr/{include,share} -type f -exec chmod -cR 644 "{}" \;
+ mv "usr/local/share/"* usr/share/
+ rmdir usr/local/share
+ mv "usr/local/"* usr/
+ rmdir usr/local
}