summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEarnestly2016-10-27 14:06:53 +0100
committerEarnestly2016-10-27 14:06:53 +0100
commit1fdb907a55a182a5bcc578a473bae176fbed9164 (patch)
treeedb8f934849d79efdfa59d09237c76acbdd50c71 /PKGBUILD
parent82ec92978b2346fe4114153c6ba144f2a0dce61e (diff)
downloadaur-1fdb907a55a182a5bcc578a473bae176fbed9164.tar.gz
wlc: use upstream wayland-protocols directly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cc4c836d098..a245f91d7b02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=wlc-git
-pkgver=0.0.6.r0.gbf922ce
+pkgver=0.0.7.r5.gf8bb91b
pkgrel=1
pkgdesc='wayland compositor library'
@@ -11,16 +11,15 @@ options=('debug' '!strip')
depends=('wayland' 'pixman' 'libxkbcommon' 'libinput' 'libx11' 'libxcb' 'libgl'
'libdrm' 'mesa' 'xcb-util-image' 'xcb-util-wm')
-makedepends=('git' 'cmake')
+makedepends=('git' 'cmake' 'wayland-protocols')
provides=('wlc')
conflicts=('wlc')
source=('git+https://github.com/Cloudef/wlc'
- 'git+https://github.com/Cloudef/chck'
- 'git+https://anongit.freedesktop.org/git/wayland/wayland-protocols')
+ 'git+https://github.com/Cloudef/chck')
-sha1sums=('SKIP' 'SKIP' 'SKIP')
+sha1sums=('SKIP' 'SKIP')
pkgver() {
cd wlc
@@ -31,16 +30,14 @@ prepare() {
cd wlc
git submodule init
git config submodule.lib/chck.url "$srcdir"/chck
- git config submodule.protos/wayland-protocols.url "$srcdir"/wayland-protocols
- git submodule update lib/chck protos/wayland-protocols
+ git submodule update lib/chck
}
build() {
cd wlc
cmake -DCMAKE_BUILD_TYPE=Upstream \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DSOURCE_WLPROTO=ON
+ -DCMAKE_INSTALL_PREFIX=/usr
make
}