summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEarnestly2016-01-22 23:36:19 +0000
committerEarnestly2016-01-22 23:36:19 +0000
commit50675f5ff1af64cbc69d07f2c7e019ae554e60b6 (patch)
treedff5490546c354185d0974628c0ac6e4cdadd675 /PKGBUILD
parent827bfa62cb4a4234920c357662cdcb7b86eb8495 (diff)
downloadaur-50675f5ff1af64cbc69d07f2c7e019ae554e60b6.tar.gz
wlc: no weak linking, most optional deps are now required
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11b1ae029877..28e388ca7db3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
pkgname=wlc-git
-pkgver=r822.359cfe7
+pkgver=r845.66425fb
pkgrel=1
-pkgdesc='Wayland compositor library.'
+pkgdesc='Wayland compositor library'
url='https://github.com/Cloudef/wlc'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('wayland' 'pixman' 'libxkbcommon' 'libinput')
-makedepends=('git' 'cmake' 'libx11' 'libxcb' 'libgl' 'xcb-util-image')
+options=('debug' '!strip')
-optdepends=('libx11: Running the compositor as an Xorg client'
- 'libxcb: Running the compositor as an Xorg client'
- 'mesa: For optional platform support (GLESv2, EGL, DRM)'
- 'nvidia: For optional platform support (GLESv2, EGL)'
- 'xcb-util-image: Needed for xwayland support.')
+depends=('wayland' 'pixman' 'libxkbcommon' 'libinput' 'libx11' 'libxcb' 'libgl'
+ 'libdrm' 'mesa' 'xcb-util-image')
+makedepends=('git' 'cmake')
provides=('wlc')
conflicts=('wlc')
-source=('git://github.com/Cloudef/wlc'
- 'git://github.com/Cloudef/chck')
+source=('git+https://github.com/Cloudef/wlc'
+ 'git+https://github.com/Cloudef/chck')
sha1sums=('SKIP' 'SKIP')
-options=('!debug' '!strip')
-
pkgver() {
cd wlc
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"