summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortgabor72023-11-19 20:30:23 +0100
committertgabor72023-11-19 20:30:23 +0100
commitcbefa976842d43113e7f0ca103347ab99cbc0b61 (patch)
treee6689d70e04eb2363630af9110021f72a5fd1541 /PKGBUILD
downloadaur-cbefa976842d43113e7f0ca103347ab99cbc0b61.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00115dca5858
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: TarkoGabor (@tgabor7)
+pkgname=wlock-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="A very simple screen locker for Wayland"
+arch=('x86_64')
+url="https://github.com/tgabor7/sl"
+license=('BSD')
+depends=('wayland' 'wayland-protocols' 'cargo')
+source=("sl-$pkgver-linux.tar.gz::https://github.com/tgabor7/sl/archive/tags/v$pkgver.tar.gz")
+b2sums=('SKIP')
+md5sums=('SKIP')
+
+pkgver() {
+ cd cbindgen
+ git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
+}
+
+prepare() {
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+}