summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRonan Pigott2020-07-28 18:49:42 -0700
committerRonan Pigott2020-07-28 18:49:42 -0700
commit102f491e5019f38aa27f95201fb34512cbdbadc6 (patch)
tree15536f323d3b2c0074352daea2805d90b2060545 /PKGBUILD
downloadaur-102f491e5019f38aa27f95201fb34512cbdbadc6.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fbd163c76e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ronan Pigott <rpigott@berkeley.edu>
+
+pkgname=wlrctl
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Utility for miscellaneous wlroots extensions'
+url='https://git.sr.ht/~brocellous/wlrctl'
+arch=('x86_64')
+license=('MIT')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://git.sr.ht/~brocellous/$pkgname/archive/v$pkgver.tar.gz"
+)
+depends=('wayland' 'libxkbcommon')
+makedepends=('scdoc' 'meson' 'ninja')
+
+md5sums=('27289bc7615fefb0eebe4f246f9138b7')
+
+build() {
+ cd "$pkgname-v$pkgver"
+ meson \
+ -Dwerror=false \
+ --prefix /usr \
+ "$srcdir/build"
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ cd "$pkgname-v$pkgver"
+ DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+}