summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Langendorf2020-02-17 16:10:37 +0100
committerTobias Langendorf2020-02-17 16:10:37 +0100
commitf7153dbaaaec5bfd058cc77b19d0775011ae0bc2 (patch)
treed7090e9cdf42f727b712047f90015051ffccbf42 /PKGBUILD
parentd6f2308cee65cf0343ce96f9b3aec55b179d03bc (diff)
downloadaur-wlrobs-hg.tar.gz
Update build to meson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ebb27875dca..bb9d0001a66a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: klardotsh <josh@klar.sh>
+# Maintainer: Tobias Langendorf <junglerobba@jngl.one>
+# Contributor: klardotsh <josh@klar.sh>
_pkgname=wlrobs
pkgname=${_pkgname}-hg
-pkgver=r12.58dab620cca0
+pkgver=r38.8345bf985e39
pkgrel=1
pkgdesc="An obs-studio plugin that allows you to screen capture on wlroots based wayland compositors"
arch=('i686' 'x86_64')
@@ -10,7 +11,7 @@ conflicts=(wlrobs)
url="https://hg.sr.ht/~scoopta/wlrobs"
license=('GPL3')
depends=('obs-studio' 'wlroots')
-makedepends=(wayland mercurial)
+makedepends=(wayland mercurial meson ninja)
source=("hg+https://hg.sr.ht/~scoopta/${_pkgname}")
md5sums=('SKIP')
_hgrepo="hg"
@@ -21,13 +22,14 @@ pkgver() {
}
build() {
- cd ${srcdir}/${_pkgname}/Release
- make || return 1
+ cd "${_pkgname}"
+ meson build
+ ninja -C build
}
package() {
mkdir -p ${pkgdir}/usr/lib/obs-plugins
- install -D -m 0644 ${srcdir}/${_pkgname}/Release/libwlrobs.so \
+ install -D -m 0644 ${srcdir}/${_pkgname}/build/libwlrobs.so \
${pkgdir}/usr/lib/obs-plugins/wlrobs.so
}