summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorq234rty2023-08-12 17:14:55 +0800
committerq234rty2023-08-12 17:16:19 +0800
commit180a2c0275ab18a821418ebac0cf3c1ac1cd6544 (patch)
tree56a7ef98f7d3ecbb58b528f96c81f141d4f3586b /PKGBUILD
parent8f14904f40f22b5ad247f022de21875c5a4d1050 (diff)
downloadaur-180a2c0275ab18a821418ebac0cf3c1ac1cd6544.tar.gz
Add a patch to fix size hints
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32e209fa96a1..8add3ee6c6d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-hidpi-xprop-git
-pkgver=0.17.0.20230309.185147
-pkgrel=1
+pkgver=0.17.0.20230803.144028
+pkgrel=2
license=(MIT)
pkgdesc='Modular Wayland compositor library (git version, with patches)'
url=https://gitlab.freedesktop.org/wlroots/wlroots
@@ -40,10 +40,12 @@ makedepends=(
xorgproto)
source=("${pkgname}::git+${url}.git"
0001-xwayland-support-HiDPI-scale.patch
- 0002-Fix-configure_notify-event.patch)
+ 0002-Fix-configure_notify-event.patch
+ 0003-Fix-size-hints-under-Xwayland-scaling.patch)
sha512sums=('SKIP'
- '0595261b7beaa382f351b74d207956a7d36e05db4e96093d68773975cd2a6d6022a03e2aee927b1286bfd382d7c9d5ec22c747b501c2b0cd9e33f1e031a00022'
- '00c0c841f6c78d941d5128f9e0337dfd36245b74f82b53a73cc453b8cd4b09d3788f5d2d397db5cacd7445f17ff07dd8875954b5d570fcb6468e3b15060cb69a')
+ 'e94c5aafa13d7b78a9e0245a78c6b937f64ac78472f22afc2ca712c330212d6f69579139b103b0fc1515e901725a91ed8132d5be58be300fd45ca57c8ca80761'
+ 'c89c9aaa26457e64dff3530c9042afbbfd45a41dcffb01020c512eaaa359811bc16e929003ef56eb6b77f380ac0381b8382cc09da6e78ca0e6d0b2642b2a68bf'
+ 'd54d1faf46a390492ae2bc44238185aead9231b41dbf76567dd0dc4b85579edd5bef29a5ee22062993d06bbf24954216ebfe9a3da4ee67cd5c8b5121925e3483')
install=wlroots-hidpi-xprop-git.install
pkgver () {
cd "${pkgname}"
@@ -59,6 +61,7 @@ prepare () {
git revert -n 18595000f3a21502fd60bf213122859cc348f9af
patch -Np1 < ../0001-xwayland-support-HiDPI-scale.patch
patch -Np1 < ../0002-Fix-configure_notify-event.patch
+ patch -Np1 < ../0003-Fix-size-hints-under-Xwayland-scaling.patch
}
build () {