summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorq234rty2024-01-27 21:25:50 +0800
committerq234rty2024-01-27 21:25:50 +0800
commit69b6ae60fd1f5b7b662f9aa57fd4c4d12b20aada (patch)
tree37f0dc8af19d84cc1bbc8b8aaf89abf9b2074e80 /PKGBUILD
parent53aa9d79188def611daffcf33d194509238e1823 (diff)
downloadaur-69b6ae60fd1f5b7b662f9aa57fd4c4d12b20aada.tar.gz
Use a patch for the revert
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 20 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2dd499053ff..bc16035da24b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=wlroots-hidpi-xprop-git
-pkgver=0.17.0.20231026.190508
+pkgver=0.18.0.20240127.123743
pkgrel=1
license=(MIT)
pkgdesc='Modular Wayland compositor library (git version, with patches)'
@@ -11,26 +11,23 @@ url=https://gitlab.freedesktop.org/wlroots/wlroots
arch=(x86_64)
provides=("libwlroots.so" "wlroots=${pkgver%%.202*}" "wlroots-git")
conflicts=(wlroots wlroots-git)
-options=(debug)
depends=(
- glslang
- libinput
- libdisplay-info
- libxcb
- opengl-driver
- xcb-util-errors
- xcb-util-renderutil
- xcb-util-wm
-
- 'libpixman-1.so'
- 'libseat.so'
- 'libudev.so'
- 'libvulkan.so'
- 'libwayland-client.so'
- 'libwayland-server.so'
- 'libxkbcommon.so'
-
- xorg-xwayland)
+ glslang
+ libinput
+ libdisplay-info
+ libxcb
+ opengl-driver
+ xcb-util-errors
+ xcb-util-renderutil
+ xcb-util-wm
+ 'libpixman-1.so'
+ 'libseat.so'
+ 'libudev.so'
+ 'libvulkan.so'
+ 'libwayland-client.so'
+ 'libwayland-server.so'
+ 'libxkbcommon.so'
+ xorg-xwayland)
optdepends=('xorg-xwayland-hidpi-xprop: HiDPI support, see https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/733')
makedepends=(
git
@@ -39,10 +36,12 @@ makedepends=(
wayland-protocols
xorgproto)
source=("${pkgname}::git+${url}.git"
+ 0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
0001-xwayland-support-HiDPI-scale.patch
0002-Fix-configure_notify-event.patch
0003-Fix-size-hints-under-Xwayland-scaling.patch)
sha512sums=('SKIP'
+ '494a40f24d6ca0e0d06a9d13d6fbb7eacfc269bd4716d22fda39528d2d750adf7630c8dc15c26b0f526c77762c774a7cd0a219c7fbbf1fd1327523f34b86fd67'
'ca05b46c8222e6982c848944ff2afe7765a2e76bb90e29c9d5b5dde9b51a0038bce8b0d52d01c390c970319ef10614ab1454a66940bf3a5b6193fc7f189afe6b'
'484c8a6848b1409a16403bf0c3e366bf5203716824c24e16efcdcdb71ff34c42b5da6e3da338fafea70ad80fcdd3d6e9f070fb809093d8b0b08ee0b2c95a4de4'
'8e3e77f6df204b6e5aa770be61fc8a6525e295cc8acdb0084ce66463e78f11702cf066640b20d7ff9560bdcdf7fa626db2e90651dcd42670250f45ac0f636854')
@@ -58,7 +57,7 @@ pkgver () {
prepare () {
cd "${pkgname}"
- git revert -n 18595000f3a21502fd60bf213122859cc348f9af
+ patch -Np1 < ../0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
patch -Np1 < ../0001-xwayland-support-HiDPI-scale.patch
patch -Np1 < ../0002-Fix-configure_notify-event.patch
patch -Np1 < ../0003-Fix-size-hints-under-Xwayland-scaling.patch
@@ -66,7 +65,6 @@ prepare () {
build () {
arch-meson \
- --buildtype=debug \
-Dwerror=false \
-Dexamples=false \
"${pkgname}" build