summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCyril Levis2020-05-23 20:52:04 +0200
committerCyril Levis2020-05-23 20:52:04 +0200
commita5e40dc7d8551a36d3186c4cee469eabc9ce4e0c (patch)
tree48936f8b536a91c74b7e7a7b6cf0851e0d82499e /PKGBUILD
parent57f620f94660d89c3fc00fc482e2e188881b4750 (diff)
downloadaur-a5e40dc7d8551a36d3186c4cee469eabc9ce4e0c.tar.gz
Initial upload: wluma-als-emulator 1.0.0-1
upgpkg: wluma-als-emulator-git 1.0.0.r0.g406f9d7-1 upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 309b4c0f0f01..7830a91ea800 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Cyrinux <pkgbuilds AT levis DOT name>
pkgname=wluma-als-emulator-git
-_gitname=wluma-als-emulator
-pkgver=master
+_pkgname=${pkgname%-git}
+pkgver=1.0.0.r0.g406f9d7
pkgrel=1
-pkgdesc="Light sensor emulator for wluma, write lux from webcam or time based to a file"
+pkgdesc="Ambient light sensor emulator for wluma"
license=(MIT)
-url=https://github.com/cyrinux/wluma-als-emulator
-depends=()
-optdepends=('wluma' 'python-pillow' 'ffmpeg')
+url="https://github.com/cyrinux/${_pkgname}"
+depends=('wluma')
+optdepends=(
+ 'python-pillow: for webcam strategy',
+ 'ffmpeg: for webcam strategy'
+)
arch=(any)
makedepends=('git')
-conflicts=('fake-light-sensor' 'fake-light-sensor-git')
+conflicts=('wluma-als-emulator')
provides=('wluma-als-emulator')
-source=('git://github.com/cyrinux/wluma-als-emulator')
-md5sums=('SKIP')
+source=("git+${url}")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/wluma-als-emulator"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}
package() {
- cd "${srcdir}/wluma-als-emulator"
- install -D -m0755 \
- "${srcdir}/wluma-als-emulator/wluma-als-emulator" \
- "$pkgdir/usr/bin/wluma-als-emulator"
+ cd "${_pkgname}"
+ make install DESTDIR="${pkgdir}"
}