summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCyril Levis2020-05-25 12:04:34 +0200
committerCyril Levis2020-05-25 12:04:34 +0200
commitaddcb97fc817c752d094491e6c4d312e67ebb27c (patch)
treefbc9ed0db7f9d4fe8341c5d60773a80c79f885b0 /PKGBUILD
parent20f43692f11cc7426d1eb89d82e30fcf6ddffb8d (diff)
downloadaur-addcb97fc817c752d094491e6c4d312e67ebb27c.tar.gz
upgpkg: wluma-als-emulator-git 1.0.0.r11.ga7afd79-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c6aed494fda..9a176668dad3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
pkgname=wluma-als-emulator-git
_pkgname=${pkgname%-git}
-pkgver=1.1.0.r0.g4567ea7
+pkgver=1.0.0.r11.ga7afd79
pkgrel=1
pkgdesc="Ambient light sensor emulator for wluma"
license=(MIT)
url="https://github.com/cyrinux/${_pkgname}"
-depends=('wluma')
+depends=('python' 'python-setuptools' 'python-dateutil' 'wluma')
optdepends=(
'python-pillow: for webcam strategy',
+ 'python-requests: for api based strategies',
'ffmpeg: for webcam strategy'
)
arch=(any)
makedepends=('git')
conflicts=('wluma-als-emulator')
provides=('wluma-als-emulator')
-source=("git+${url}")
+source=("git+${url}#branch=develop")
sha256sums=('SKIP')
pkgver() {
@@ -24,7 +25,15 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}
+build() {
+ cd "${_pkgname}"
+ make build
+}
+
package() {
cd "${_pkgname}"
make install DESTDIR="${pkgdir}"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -m644 docs/* README.rst "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}