summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Nader2021-07-23 18:26:16 +0900
committerJason Nader2021-07-23 18:26:16 +0900
commit8d949d5bb3f5b06f6496b1581d71ab515372ce41 (patch)
tree25d07969a7c57c0526ceb1434336e118bb013b32 /PKGBUILD
downloadaur-8d949d5bb3f5b06f6496b1581d71ab515372ce41.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b35894e3468
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=wlvncc-git
+_pkgname=wlvncc
+pkgver=r43.1ca82ce
+pkgrel=1
+pkgdesc='Wayland native VNC client'
+arch=(x86_64 i686 aarch64 armv7h)
+url=https://github.com/any1/wlvncc
+license=(custom:ISC)
+depends=(aml-git libvncserver-git libxkbcommon pixman wayland)
+makedepends=(git meson ninja gcc pkg-config wayland-protocols)
+source=("git+$url")
+sha512sums=('SKIP')
+conflicts=(wlvncc)
+provides=(wlvncc=${pkgver%+*})
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson wlvncc build # --prefix /usr
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm 644 wlvncc/COPYING -t "$pkgdir"/usr/share/licenses/$pkgname
+}