summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-05-24 00:23:24 -0600
committerBrian Bidulock2015-05-24 00:23:24 -0600
commitf81a4c8f939f1aea7c99af188d09196045223944 (patch)
tree521083e2fed878b26e7a4da4ba75c69b1dfa61e5 /PKGBUILD
downloadaur-f81a4c8f939f1aea7c99af188d09196045223944.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f71915576c17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Henrik Tunedal <putte_xvi at tunedal dot nu>
+pkgname=wmbattery
+pkgver=2.41
+pkgrel=1
+pkgdesc="Battery monitor dockapp for Window Maker"
+arch=(i686 x86_64)
+url="http://kitenet.net/~joey/code/wmbattery/"
+license=('GPL')
+depends=(libxpm hal)
+source=(git://git.kitenet.net/wmbattery#tag=2.41
+ disable-apm.patch)
+md5sums=('SKIP'
+ 'c5e2a979ade6d16069065c93f2cf2402')
+
+build() {
+ cd "$srcdir/$pkgname"
+ patch -p1 <../disable-apm.patch || return 1
+ autoreconf -fiv || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}