summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 22:37:08 -0600
committerBrian Bidulock2015-06-10 22:37:08 -0600
commitefdd553c590ddc2fc8e31600f0da634920094452 (patch)
treee3efc197aece8cd8ddfaeebc4328de789e811c59 /PKGBUILD
downloadaur-efdd553c590ddc2fc8e31600f0da634920094452.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..baea5306e74a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: libernux <dutchman55@gmx.com>
+pkgname=wmcalc
+pkgver=0.3
+pkgrel=4
+pkgdesc="Dockapp that performs all the functions (and eventually more) of a simple four function calculator"
+arch=('i686' 'x86_64')
+#url="http://dockapps.windowmaker.org/file.php/id/130"
+url="http://web.archive.org/web/20121025065535/http://dockapps.windowmaker.org/file.php/id/130"
+license=('GPL')
+groups=('x11')
+depends=('libxpm')
+#source=("http://dockapps.windowmaker.org/download.php/id/455/$pkgname-$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz")
+md5sums=('23ecf19e956d19ef9dddb810989666c5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make clean
+ make INCLUDES=-I/usr/include/X11
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 .wmcalc "$pkgdir/usr/share/doc/$pkgname/wmcalc.example"
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
+}