summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Pereira2022-07-28 14:55:20 -0300
committerDaniel Pereira2022-07-28 14:55:20 -0300
commitaabae8a907ada67cebbde5a5954be8c003d891bb (patch)
tree4cfd558b66df55735611cafa780e2abfd786c246 /PKGBUILD
downloadaur-aabae8a907ada67cebbde5a5954be8c003d891bb.tar.gz
feat: initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d3939e732a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Daniel Pereira <daniel@garajau.com.br>
+
+pkgname=wmcompanion
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Desktop system event listener for minimal window manager users"
+url="https://github.com/kriansa/wmcompanion"
+arch=(any)
+license=(Apache)
+depends=(python python-dbus-next)
+makedepends=(python-poetry python-installer)
+source=("https://github.com/kriansa/wmcompanion/archive/v${pkgver}.tar.gz")
+sha256sums=(40cba25334bd04e52b7dd61c17daeb80cb67186108a98135e44877d7ab3204d1)
+
+build() {
+ cd "$pkgname-$pkgver" || exit 1
+ poetry build -f wheel
+}
+
+package() {
+ cd "$pkgname-$pkgver" || exit 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}