summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-07-02 23:28:22 +0200
committersl1pkn072015-07-02 23:28:22 +0200
commitd832500b62d9cf671088eb2f695c80163ac576b3 (patch)
tree94002acee7101e076d330173eb7b692ea1f30f2d /PKGBUILD
downloadaur-d832500b62d9cf671088eb2f695c80163ac576b3.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a773b0e45bb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=wobbly-git
+pkgver=r4.2.g8f9b54d
+pkgrel=1
+pkgdesc="IVTC assistant for VapourSynth, similar to Yatta. (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/dubhater/Wobbly'
+license=('GPL')
+depends=('qt5-base' 'vapoursynth-plugin-fieldhint-git' 'vapoursynth-plugin-d2vsource-git')
+makedepends=('git')
+provides=('wobbly')
+conflicts=('wobbly')
+source=('wobbly::git+https://github.com/dubhater/Wobbly.git'
+ 'wobbly.desktop')
+sha1sums=('SKIP'
+ '0fda5064306cf489879fa5234c8baf40879bb805')
+install=wobbly-git.install
+
+pkgver() {
+ cd wobbly
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd wobbly
+ ./autogen.sh
+}
+
+build() {
+ cd wobbly
+ ./configure --prefix=/usr
+ make --trace
+}
+
+package() {
+ make -C wobbly DESTDIR="${pkgdir}" install
+
+ install -Dm644 wobbly.desktop "${pkgdir}/usr/share/applications/wobbly.desktop"
+}