summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBarbUk2023-05-25 15:07:27 +0200
committerBarbUk2023-05-25 15:07:27 +0200
commit2fe7470eac335832f4ae96f1a1f06d15ffc34bec (patch)
treee6c5e7b84af48d0aedaa593b0163a85370b4b2c8 /PKGBUILD
parentb0f30a7c896e07df40197f88b37968b9c0f703f8 (diff)
downloadaur-2fe7470eac335832f4ae96f1a1f06d15ffc34bec.tar.gz
Bump to 0.2.12 and use python build / install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 12 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca5484dc0ccf..bea42efb60b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jakub SzymaƄski <jakubmateusz@poczta.onet.pl>
pkgname=woeusb-ng
-pkgver=0.2.10
+pkgver=0.2.12
pkgrel=1
pkgdesc="Simple tool that enable you to create your own usb stick with Windows installer."
arch=('any')
@@ -18,9 +18,8 @@ depends=(
'xdg-utils'
'python-termcolor'
)
-makedepends=(
- 'python-setuptools'
-)
+makedepends=(python-build python-installer python-wheel)
+
provides=('woeusb')
conflicts=(
'woeusb'
@@ -28,34 +27,24 @@ conflicts=(
)
source=(
"https://github.com/WoeUSB/WoeUSB-ng/archive/v$pkgver.tar.gz"
+ "pr79.patch"
)
-sha256sums=(
- "ee036451ec4878bd6ec6f16232cb27428c452aacdd62ea42d1a75075246d76f9"
-)
+sha256sums=('64b9346490e88c627f0034973771620474acb9482bb6a5045c27e52d23987779'
+ '848e56d1b377a46bba6f8c400f7b7aea18aba263f6c795158e219fbad9c87ed6')
+prepare() {
+ cd WoeUSB-ng-$pkgver
+ patch --forward --strip=1 --input="${srcdir}/pr79.patch"
+}
build() {
cd WoeUSB-ng-$pkgver
-
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd WoeUSB-ng-$pkgver
-
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
-
- mkdir -p $pkgdir/usr/bin
- mkdir -p $pkgdir/usr/share/icons/WoeUSB-ng
- mkdir -p $pkgdir/usr/share/applications
- mkdir -p $pkgdir/usr/share/polkit-1/actions
-
- # scripts
- cp WoeUSB/woeusb WoeUSB/woeusbgui $pkgdir/usr/bin
-
- # icon
- cp WoeUSB/data/icon.ico $pkgdir/usr/share/icons/WoeUSB-ng/icon.ico
-
+ python -m installer --destdir="$pkgdir" dist/*.whl
# shortcut
cp miscellaneous/WoeUSB-ng.desktop $pkgdir/usr/share/applications/WoeUSB-ng.desktop
chmod 755 $pkgdir/usr/share/applications/WoeUSB-ng.desktop