summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakub Szymański2021-02-06 18:35:12 +0100
committerJakub Szymański2021-02-06 18:35:12 +0100
commitdc7e4ccac895b39fe37d27f40fb4a21897a83d08 (patch)
tree24c814efcddb6fee0806c59f3d6d11c77d491bc4 /PKGBUILD
parent88b9569627e3548cf45217a763b0ce953c142141 (diff)
downloadaur-dc7e4ccac895b39fe37d27f40fb4a21897a83d08.tar.gz
Update to 0.2.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b604794b89cd..67c6582ac420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jakub Szymański <jakubmateusz@poczta.onet.pl>
pkgname=woeusb-ng
-pkgver=0.2.5
-pkgrel=3
+pkgver=0.2.7
+pkgrel=1
pkgdesc="Simple tool that enable you to create your own usb stick with Windows installer."
arch=('any')
url="https://github.com/WoeUSB/WoeUSB-ng"
@@ -16,36 +16,32 @@ depends=(
'python-pip'
'python-wxpython'
'xdg-utils'
+ 'python-termcolor'
)
makedepends=(
- 'git'
'python-setuptools'
)
-optdepends=('python-termcolor: Colored text')
provides=('woeusb')
conflicts=(
'woeusb'
'woeusb-git'
)
source=(
- "git+https://github.com/WoeUSB/WoeUSB-ng.git"
+ "https://github.com/WoeUSB/WoeUSB-ng/archive/v0.2.7.tar.gz"
)
sha256sums=(
- 'SKIP'
+ "4546ca5cf703434602b9dac2724cbfe791bbbc21c9b72d01c655ff7b89d69672"
)
build() {
- cd WoeUSB-ng
-
- git checkout v$pkgver
- git apply ../../AUR.patch || echo "Failed to apply patch"
+ cd WoeUSB-ng-$pkgver
python setup.py build
}
package() {
- cd WoeUSB-ng
+ cd WoeUSB-ng-$pkgver
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
@@ -65,5 +61,5 @@ package() {
chmod 755 $pkgdir/usr/share/applications/WoeUSB-ng.desktop
# policy
- cp miscellaneous/com.github.woeusb.woeusb-ng.policy $pkgdir/usr/share/polkit-1/actions/com.github.woeusb.woeusb-ng.policy
+ cp ../../com.github.woeusb.woeusb-ng.policy $pkgdir/usr/share/polkit-1/actions/com.github.woeusb.woeusb-ng.policy
} \ No newline at end of file