summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornick2023-01-10 17:33:02 +0100
committernick2023-01-10 17:33:02 +0100
commit2971696921f18aa2462498ac26ef7ab921433546 (patch)
tree9829f3fd2e42a63ec28fbbd5d53e2b3d7ee70fc9 /PKGBUILD
downloadaur-2971696921f18aa2462498ac26ef7ab921433546.tar.gz
wofi-pass-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb02d395f5c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: noobping <hello@noobping.dev>
+
+pkgname=wofi-pass-git
+_pkgname=${pkgname%-git}
+pkgver=VERSION
+pkgrel=1
+pkgdesc="A Wayland-native interface for conveniently using pass"
+arch=('any')
+url='https://github.com/TinfoilSubmarine/wofi-pass'
+license=('GPL')
+depends=('coreutils' 'findutils' 'grep' 'man-pages' 'pass' 'tcl' 'util-linux' 'wl-clipboard' 'wofi')
+optdepends=(
+ 'wtype: type support'
+ 'pass-otp: OTP support')
+source=("git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 "${_pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}