summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hauser-Raspe2023-01-09 22:16:56 +0000
committerMichael Hauser-Raspe2023-01-09 22:16:56 +0000
commit724ee3566ab905a1b0a7c510d22e9ff3f8fc2717 (patch)
tree426abfa23bd9526d959f02f09f15c8baf1e7c5be /PKGBUILD
downloadaur-wofi-symbol-git.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef5cc5b6a248
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Michael Hauser-Raspe
+_pkgname=wofi-symbol
+pkgname=${_pkgname}-git
+pkgver=0.r26
+pkgrel=1
+pkgdesc="Symbol picker for Wayland using wofi and wtype"
+arch=("any")
+url="https://github.com/mijoharas/wofi-symbol"
+license=("MIT")
+optdepends=("wofi" "wtype") # thanks to gilbs https://aur.archlinux.org/account/gilbs
+makedepends=("git")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${pkgname}::git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ echo "0.r$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm755 ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}