summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSlashbunny2010-08-18 20:04:42 -0400
committerSlashbunny2010-08-18 20:04:42 -0400
commit64b0abc3b825200af766bcfa03fd6196989667d5 (patch)
treeaca721548a4fa2b118cb7568240ca3e3763249d4 /PKGBUILD
parent9e4d8094ce3db7edc034f72decc8bdcdd86d5191 (diff)
downloadaur-64b0abc3b825200af766bcfa03fd6196989667d5.tar.gz
Added 64bit support (thanks babets)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57fb34078ad1..9d62a690f6a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
pkgname=wolf
pkgver=1.41b
-pkgrel=3
+pkgrel=4
pkgdesc="Return to Castle Wolfenstein is a single and multiplayer first person shooter. You need the retail game files to play."
arch=('i686')
url="http://zerowing.idsoftware.com/linux/wolf/"
license=('custom')
-depends=('libgl' 'libxext')
-makedepends=()
+[ "${CARCH}" = "i686" ] && depends=('libgl' 'libxext')
+[ "${CARCH}" = "x86_64" ] && depends=('lib32-libgl' 'lib32-libxext')
+optdepends=('xdg-utils: for opening urls'
+ 'et-sdl-sound: for sdl/alsa support')
install='wolf.install'
source=('wolfsp.desktop' 'wolfmp.desktop' \
'wolf.launcher' 'wolfsp.launcher' 'wolfmp.launcher' 'wolfded.launcher' \
@@ -91,5 +93,12 @@ build() {
# Install Icon File (Multi Player)
install -D -m 644 $pkgdir/opt/wolf/WolfMP.xpm \
$pkgdir/usr/share/pixmaps/WolfMP.xpm
-}
+ # Remove Licenses from Data Directory
+ rm $pkgdir/opt/wolf/Docs/License.txt
+ rm $pkgdir/opt/wolf/pb/PB_EULA.txt
+
+ # Use a more modern way for opening urls
+ rm $pkgdir/opt/wolf/openurl.sh
+ ln -s /usr/bin/xdg-open $pkgdir/opt/wolf/openurl.sh
+}