summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZion Nimchuk2021-05-19 14:57:18 -0700
committerZion Nimchuk2021-05-19 14:57:18 -0700
commit11c6b960a7f95aeb6e5ece31d34a9c98e9650b10 (patch)
tree12b2b1dd256310f34377f7cb630640978c5f3cef /PKGBUILD
parentfe583126ccbf6290a252144011b5566573e91556 (diff)
downloadaur-11c6b960a7f95aeb6e5ece31d34a9c98e9650b10.tar.gz
Use both CMake and traditional Makefiles to build so we install all supported build system files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 22 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0058ce47b89..4e706a5812f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=wolfssl
pkgver=4.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='small, fast, portable implementation of TLS/SSL for embedded devices to the cloud (formerly CyaSSL)'
arch=(i686 x86_64)
license=(GPL)
@@ -32,9 +32,29 @@ build() {
-DWOLFSSL_FAST_MATH=OFF \
-DWOLFSSL_CRYPT_TESTS=OFF
make
+
+ # Run make using Makefiles so that we also provide the regular pkg-config files
+ cd ../$pkgname-$pkgver-stable
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-fastmath \
+ --disable-fasthugemath \
+ --disable-bump \
+ --enable-opensslextra \
+ --enable-fortress \
+ --enable-keygen \
+ --enable-certgen \
+ --disable-debug \
+ --disable-ntru \
+ --disable-examples \
+ --enable-distro \
+ --enable-reproducible-build
+ make
}
package() {
make -C build install DESTDIR="$pkgdir"
- install -Dm644 $pkgname-$pkgver-stable/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ cd $pkgname-$pkgver-stable
+ make install DESTDIR="$pkgdir"
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ libtool --finish /usr/lib
}