summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlibele2022-08-12 16:37:54 -0500
committerlibele2022-08-12 16:37:54 -0500
commitbef58f1b425443c0b0b836a4c71353edda362d2e (patch)
treef1818a480f5c1c6ebfc39e0aee5f86beeb6b00e5 /PKGBUILD
parent55c5cf554428a39cfbb540a12299ba09cca46018 (diff)
downloadaur-bef58f1b425443c0b0b836a4c71353edda362d2e.tar.gz
version 20220113
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da41c8d8c397..1d36b479491e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
-# Maintainer: Schroedinger <1181822466 at qq dot com>
+# Maintainer: libele <libele@disroot.org>
+# Contributor: Schroedinger <1181822466 at qq dot com>
# Contributor: dacoit <dacoit at tuta.io>
# Contributor: Andreas B. Wagner <AndreasBWagner@pointfree.net>
# Contributor: Aaron Schaefer <aaron@elasticdog.com>
# Contributor: Evan Gates <evan.gates at gmail dot com>
# Contributor: Vardyr <vardyr.al at insocada dot com>
+
pkgname=woof
-pkgver=20200624
+pkgver=20220113
pkgrel=1
pkgdesc='An ad-hoc single file webserver; Web Offer One File'
arch=('any')
url="http://www.home.unix-ag.org/simon/$pkgname.html"
license=('GPL2')
depends=('python3')
+makedepends=('git')
conflicts=()
source=("git+https://github.com/simon-budig/$pkgname")
md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
package() {
cd "$srcdir/$pkgname"
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"