summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfenuks2017-08-05 11:48:19 +0200
committerfenuks2017-08-05 11:48:19 +0200
commit81ae7b290061e28f5263568cdfad7ea7e67d0600 (patch)
treea9751e04a406cf54258e9b59e65e0434bfc97b77 /PKGBUILD
downloadaur-81ae7b290061e28f5263568cdfad7ea7e67d0600.tar.gz
Initial release; version 20170729-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bd03c1a9387
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: fenuks
+# TODO: check if using https://sjp.pl/slownik/ort/ won't be better idea
+
+pkgname=words-pl
+pkgver=20170729
+pkgrel=1
+pkgdesc="A ‘words’ file for Polish language"
+arch=("any")
+url="https://sjp.pl/slownik/odmiany/"
+license=("GPL" "LGPL" "Apache" "CCPL")
+depends=()
+optdepends=()
+makedepends=("dos2unix")
+conflicts=("${pkgname}")
+# install=$pkgname.install
+source=("https://sjp.pl/slownik/odmiany/sjp-odm-${pkgver}.zip")
+md5sums=('3b85dfeeeecb7ead69124e2e5367b8bb')
+sha256sums=('f9bdb5cee88e755d2c35c9f2f11510bee3317e3a3dda0e302b1feb959c03fd66')
+
+build() {
+ cd "${srcdir}"
+ grep -v '^\?' odm.txt | sed 's/, /\n/g' > polish
+ dos2unix polish
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm644 polish "$pkgdir/usr/share/dict/polish"
+}