summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron Fischer2021-02-24 21:13:00 +0100
committerAaron Fischer2021-02-24 21:15:13 +0100
commit745cdfb9fa224c10409249410c3761236e151ae9 (patch)
tree884f5443ce8c4ca803528132c1c66d38fae8f362 /PKGBUILD
parentb35dd6e43628993e305d61a9688514684198a337 (diff)
downloadaur-745cdfb9fa224c10409249410c3761236e151ae9.tar.gz
Remove the pthread workaround, thanks to @frankspace
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 3 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 259cf794eac1..88cf29791e13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
# Contributor: J. W. Birdsong <jwbirdsong AT gmail DOT com>
# Contributor: Kevin Piche <kevin@archlinux.org>
+# Contributor: Frank Carlyle McLaughlin <frank@frankspace.com>
pkgname=worker
pkgver=4.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="A file manager for the X Window System"
arch=('i686' 'x86_64')
license=('GPL')
@@ -21,19 +22,7 @@ validpgpkeys=('F9299EE90A729029E71AF26B667132D0FBC52B37') # Ralf Hoffmann
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- # We need to disable the optimizations because of a bug in gcc
- # (see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63140 for details)
- # Ralf added a gcc constraint check to avoid compiling bad optimized code.
- # Because we run a recent version of gcc, we disable the check, and
- # disable also the compiler optimizations completely. Because the code
- # uses some C++11 features, we need to set this explicitly.
- #
- # To bypass the pthread bug, the LDFLAGS is set here explicit until
- # the bug is solved. See here for more detail and progress:
- # https://sourceforge.net/p/workerfm/mailman/message/34136485/
- CPPFLAGS="-O0 -std=gnu++14" LDFLAGS=-pthread ./configure --enable-xft --prefix=/usr --disable-cxx-check
-
+ ./configure --enable-xft --prefix=/usr
make
}