summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwowario2021-06-25 22:24:00 +0300
committerwowario2021-06-25 22:24:00 +0300
commit59ccc913c240e2c0c28b1f9c9c9003c35ec34c4c (patch)
tree4febb0b807ccd3f210b04a71b15f586f4a41160d /PKGBUILD
parentcfc708e4245bb5f9ce6a0a59b43fffee1d0dffba (diff)
downloadaur-59ccc913c240e2c0c28b1f9c9c9003c35ec34c4c.tar.gz
update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 1 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4215b8151c03..81987df199a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,30 +11,13 @@ depends=('boost-libs' 'libunwind' 'openssl' 'readline' 'zeromq' 'pcsclite' 'hida
makedepends=('git' 'cmake' 'boost')
source=(
"${pkgname}"::"git+https://git.wownero.com/wownero/wownero.git#branch=dev-v0.10"
- "git+https://github.com/monero-project/unbound.git"
- "git+https://github.com/monero-project/supercop.git"
- "git+https://github.com/monero-project/miniupnp.git"
- "git+https://github.com/Tencent/rapidjson.git"
- "git+https://git.wownero.com/wownero/RandomWOW.git#branch=1.1.9-wow"
monero-boost1.76.patch::https://github.com/selsta/monero/commit/c28d2f7c.patch)
sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'SKIP')
prepare() {
cd "${pkgname}"
- git submodule init
- git config submodule.external/unbound.url "$srcdir/unbound"
- git config submodule.external/supercop.url "$srcdir/supercop"
- git config submodule.external/miniupnp.url "$srcdir/miniupnp"
- git config submodule.external/rapidjson.url "$srcdir/rapidjson"
- git config submodule.external/RandomWOW.url "$srcdir/RandomWOW"
- git submodule update
-
+ git submodule update --init --recursive
patch -p1 < ../monero-boost1.76.patch # Fix build with boost 1.76
}