summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwowario2021-09-02 07:52:46 +0300
committerwowario2021-09-02 07:52:46 +0300
commite8e4bb01a3cfdc929d76208d07656a15bb7f8071 (patch)
tree2533b97f3de03cb998691705e3f7fd389df27e33 /PKGBUILD
parenta7cf8d9dca2a1c1945faf5c41196cdfc7a3cd24f (diff)
downloadaur-e8e4bb01a3cfdc929d76208d07656a15bb7f8071.tar.gz
add pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a9d4fc1eec9..3821140f1eec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: wowario <wowario[at]protonmail[dot]com>
pkgname=wownero-git
-pkgver=0.10.1.0
+pkgver=0.10.1.0.8ab87421d9
pkgrel=1
pkgdesc="Wownero: a fairly launched privacy-centric meme coin with no premine and a finite supply"
license=('BSD')
@@ -30,6 +30,11 @@ sha512sums=('SKIP'
'SKIP')
)
+pkgver() {
+ cd "${pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd "${pkgname}"
git submodule init