summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Fields2016-01-08 18:56:21 -0500
committerMatt Fields2016-01-08 18:58:52 -0500
commitc5f2f29769a229075f2e755808cedf51225b7cbe (patch)
treee1dc7a6ab764fe028efed0062ce2405156d8fc85 /PKGBUILD
parent5a9415f4d093671649381796509fef21624ae6fc (diff)
downloadaur-c5f2f29769a229075f2e755808cedf51225b7cbe.tar.gz
Update to 0.22.0
The extra composer.json file dependency and subsequent copy command have been removed as they are no longer needed. The composer versions in the current download work correctly out of the box with the phar build scripts.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49bf6b8cccd4..c88ecfda2e24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=wp-cli
-pkgver=0.21.1
+pkgver=0.22.0
pkgrel=1
pkgdesc="A command-line tool for managing WordPress"
url="http://wp-cli.org/"
@@ -12,11 +12,9 @@ conflicts=()
replaces=()
backup=()
source=("https://github.com/wp-cli/wp-cli/archive/v${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/wp-cli/wp-cli/v${pkgver}/utils/wp-completion.bash"
- "https://raw.githubusercontent.com/wp-cli/wp-cli/a249578ae2053b88c3174b15378266c9c65a9dfe/composer.json")
-md5sums=('aab4f251b9ab79e73f9ea17fb6fb8db9'
- 'f8acb424f1460428796451679631be86'
- '7359993f535213af66c2148ea27369b3')
+ "https://raw.githubusercontent.com/wp-cli/wp-cli/v${pkgver}/utils/wp-completion.bash")
+md5sums=('035a6009bc2d10a4e285742eb65498a0'
+ 'f8acb424f1460428796451679631be86')
prepare() {
if [[ -n $(php -r '$phar = new Phar("test.phar", 0,"wp-cli.phar");' 2>&1 | grep "Class 'Phar' not found") ]]; then
@@ -38,8 +36,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- cp ../composer.json .
- composer update --no-interaction --prefer-dist
+ composer install --no-interaction --prefer-dist
php -dphar.readonly=0 utils/make-phar.php wp-cli.phar --quiet
}