summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Fields2016-12-06 09:29:21 -0500
committerMatt Fields2016-12-06 09:29:21 -0500
commitcb8ecdcc2fe882bf5718338484cc9ca638598c32 (patch)
tree63bdb584c1d33e0fe80c1b16f493b5f454e50f0e /PKGBUILD
parent2fb92a551cc3d74e73820837f2f8af8fc00241b7 (diff)
downloadaur-cb8ecdcc2fe882bf5718338484cc9ca638598c32.tar.gz
More lenient with phar.readonly
We used to error if phar.readonly was not set to 0. However, since we can change it with a commandline param at runtime we can be a bit more lenient. Now only errors if it was still not able to build a test phar even when using the commandline paramater to disable phar.readonly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23894fa5eae2..e5d1be8b1936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=wp-cli
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A command-line tool for managing WordPress"
url="http://wp-cli.org/"
arch=('any')
@@ -17,13 +17,13 @@ md5sums=('155256f4119b616aae2dd760d33403b3'
'f8acb424f1460428796451679631be86')
prepare() {
- if [[ -n $(php -r '$phar = new Phar("test.phar", 0,"wp-cli.phar");' 2>&1 | grep "Class 'Phar' not found") ]]; then
+ if [[ -n $(php -dphar.readonly=0 -r '$phar = new Phar("test.phar", 0,"wp-cli.phar");' 2>&1 | grep "Class 'Phar' not found") ]]; then
echo "Error: Phar extension not found! Enable the phar extension in your php.ini"
echo "Also be sure to disable the readonly setting for the phar extension: Set phar.readonly to Off"
return 1
fi
- if [[ -n $(php -r '$phar = new Phar("test.phar", 0,"wp-cli.phar");' 2>&1 | grep "phar.readonly") ]]; then
+ if [[ -n $(php -dphar.readonly=0 -r '$phar = new Phar("test.phar", 0,"wp-cli.phar");' 2>&1 | grep "phar.readonly") ]]; then
echo "Error: Phar readonly setting is enabled!"
echo "Disable the readonly setting for the phar extension in your php.ini: Set phar.readonly to Off"
return 1