summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Fields2015-12-14 18:20:43 -0500
committerMatt Fields2015-12-14 18:20:43 -0500
commitdfb37a05bff8e36794ffedcd54a3f7810a0600dc (patch)
tree8d65fcd39e85804cea87ed69816556bd127a0732 /PKGBUILD
parent6a403431a7408ae517f13d80b5fefc855235f1bc (diff)
downloadaur-dfb37a05bff8e36794ffedcd54a3f7810a0600dc.tar.gz
Updated to version 0.21.1 with a temporary patch for composer.json
The composer.json included in the 0.21.1 release grabs the 2.8 version of the symfony/console package, which includes a dependency on symfony/polyfill-mbstring. This dependency is not copied into the compiled phar, and as such when composer tries to run during the phar's execution it errors with a requirement error. Rather than trying to patch the util/make-phar.php file to include the symfony/polyfill-mbstring dependency, there is a composer.json file from the wp-cli/wp-cli repository which locks the symfony component versions to 2.7.*, which prevents the symfony/polyfill-mbstring dependency from being required. This is the method the wp-cli authors are using going forward, so it is implemented here as well. The composer.json requirement and copy command in the build() section will most likely be able to be removed in the next version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2b56284ed35..0de9b6d2cc57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=wp-cli
-pkgver=0.20.0
+pkgver=0.21.1
pkgrel=2
pkgdesc="A command-line tool for managing WordPress"
url="http://wp-cli.org/"
@@ -12,9 +12,11 @@ conflicts=()
replaces=()
backup=()
source=("https://github.com/wp-cli/wp-cli/archive/v${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/wp-cli/wp-cli/v${pkgver}/utils/wp-completion.bash")
-md5sums=('ed540f7929b5480ab3e533bd1a91f57a'
- 'f8acb424f1460428796451679631be86')
+ "https://raw.githubusercontent.com/wp-cli/wp-cli/v${pkgver}/utils/wp-completion.bash"
+ "https://raw.githubusercontent.com/wp-cli/wp-cli/a249578ae2053b88c3174b15378266c9c65a9dfe/composer.json")
+md5sums=('aab4f251b9ab79e73f9ea17fb6fb8db9'
+ 'f8acb424f1460428796451679631be86'
+ '7359993f535213af66c2148ea27369b3')
prepare() {
if [[ -n $(php -r '$phar = new Phar("test.phar", 0,"wp-cli.phar");' 2>&1 | grep "Class 'Phar' not found") ]]; then
@@ -36,7 +38,8 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- composer install --no-interaction --prefer-dist
+ cp ../composer.json .
+ composer update --no-interaction --prefer-dist
php -dphar.readonly=0 utils/make-phar.php wp-cli.phar --quiet
}