summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordeviantfero2016-03-12 23:24:35 -0600
committerdeviantfero2016-03-12 23:24:35 -0600
commit3d212c44df38aee9d7604bd31dde24e4ca0eba3e (patch)
treef8a9521747f94d0e63689712250c25808f2e9d89 /PKGBUILD
downloadaur-3d212c44df38aee9d7604bd31dde24e4ca0eba3e.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b43c6ae4ce2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Fernando Vasquez <fmorataya.04@gmail.com>
+
+_gitname=wpgtk
+pkgname="${_gitname}-git"
+_gitbranch=master
+_gitauthor=deviantfero # djmelik
+pkgver=r96.ba82065
+pkgrel=1
+pkgdesc="A gui wallpaper chooser that changes your Openbox theme, GTK theme and Tint2 theme"
+url="https://github.com/${_gitauthor}/${_gitname}"
+license=('BSD')
+source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}")
+sha512sums=('SKIP')
+arch=('any')
+depends=('python' 'python2' 'python2-pillow' 'feh' 'python-gobject' 'gtk3' 'libxslt')
+makedepends=('git')
+optdepends=()
+conflicts=("${_gitname}")
+provides=("${_gitname}")
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ echo "#!/bin/bash" > ./wpg
+ echo "/usr/bin/wpgtk/src/wpg.py" >> ./wpg
+ mkdir -p ${pkgdir}/usr/bin/wpgtk/py
+ mkdir -p ${pkgdir}/usr/bin/wpgtk/src
+ install -D -m755 ./py/* ${pkgdir}/usr/bin/wpgtk/py
+ install -D -m755 ./src/* ${pkgdir}/usr/bin/wpgtk/src
+ install -D -m775 ./wp ${pkgdir}/usr/bin/wp
+ install -D -m775 ./wpg ${pkgdir}/usr/bin/wpg
+ install -D -m755 ./functions ${pkgdir}/usr/bin/wpgtk/functions
+ bash ./installaur.sh
+}
+
+# vim:set et sw=2 sts=2 tw=80: