summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordeviantfero2020-02-10 02:16:37 -0600
committerdeviantfero2020-02-10 02:16:37 -0600
commit497e3a154644204d42a835ad63ba6b5eb3bfa8bd (patch)
tree971a73e480a6597ab26e823f8d96d264ab27eb93 /PKGBUILD
parentdf746277d2bf5c3769e3406ce8d3394bff3b18c9 (diff)
downloadaur-497e3a154644204d42a835ad63ba6b5eb3bfa8bd.tar.gz
Update xsettingsd dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 733d357f3d75..81764ea88595 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,20 @@ _gitname=wpgtk
pkgname="${_gitname}-git"
_gitbranch=master
_gitauthor=deviantfero # deviantfero
-pkgver=r668.17f6666
+pkgver=r752.64b4523
pkgrel=1
pkgdesc="A gui wallpaper chooser that changes your Openbox theme, GTK theme and Tint2 theme"
url="https://github.com/${_gitauthor}/${_gitname}"
license=('GPLv2')
-source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}")
-sha512sums=('SKIP')
+source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}"
+ "wpgtk.png::https://github.githubassets.com/images/icons/emoji/unicode/1f3b4.png")
+noextract=('wpgtk.png')
+sha512sums=('SKIP' 'SKIP')
arch=('any')
depends=('python' 'python-pillow' 'python-gobject' 'gtk3' 'libxslt' 'python-pywal')
optdepends=('feh: set wallpaper'
'nitrogen: set wallpaper'
- 'xsettingsd-git: live reload GTK+ theme')
+ 'xsettingsd: live reload GTK+ theme')
conflicts=("${_gitname}")
provides=("${_gitname}=$pkgver")
@@ -32,6 +34,10 @@ package() {
install -Dm644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "$srcdir/$_gitname/$_gitname/misc/wpg.conf" \
"usr/etc/$_gitname/wpg.conf"
+ install -Dm644 "$srcdir/$_gitname/$_gitname/misc/wpgtk.desktop" \
+ "$pkgdir/usr/share/applications/wpgtk.desktop"
+ install -Dm644 "$srcdir/wpgtk.png" \
+ "$pkgdir/usr/share/pixmaps/wpgtk.png"
install -Dm644 "$srcdir/$_gitname/completions/bash/wpg" \
"usr/share/bash-completion/wpg"
install -Dm644 "$srcdir/$_gitname/completions/zsh/_wpg" \