summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2018-10-01 16:27:05 +0200
committeranthraxx2018-10-01 16:27:05 +0200
commit9b8a4085f2f9f2490baca1861470ab9ab34c4dd9 (patch)
tree90731d6cea71eb92bc2d4bb74ae66bb7413b66b9 /PKGBUILD
parent6f86b1c77be3aa7e1f853662d9dda13c26163f2b (diff)
downloadaur-wpscan-git.tar.gz
upgpkg: wpscan-git 3.3.1.2303.3a427728-1 (fix build for new version)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90f3892a65f4..12da21d5a776 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname=wpscan
pkgname=wpscan-git
-pkgver=2.9.4.2282.fd660632
+pkgver=3.3.1.2303.3a427728
pkgrel=1
pkgdesc='Black box WordPress vulnerability scanner'
url='http://wpscan.org'
arch=('x86_64')
license=('custom:WPScan')
-depends=('ruby-bundler' 'libxslt' 'libyaml' 'curl')
-makedepends=('git' 'unzip')
+depends=('ruby-bundler' 'libxslt' 'libyaml' 'curl' 'libxml2')
+makedepends=('git')
provides=('wpscan')
conflicts=('wpscan')
options=('!strip' '!emptydirs')
@@ -20,22 +20,18 @@ sha512sums=('SKIP')
pkgver() {
cd ${pkgname}
- printf "%s.%s.%s" "$(git describe --tags --abbrev=0)" \
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|sed 's/^v//')" \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd ${pkgname}
- unzip -o data.zip
- rm data.zip
- # replace cache location with local user share
- sed "s|ROOT_DIR, 'cache'|ENV['HOME'] + '/.local/share/${_pkgname}/cache'|" -i lib/common/common_helper.rb
- sed "s|ROOT_DIR, 'log.txt'|ENV['HOME'] + '/.local/share/${_pkgname}/log.txt'|" -i lib/common/common_helper.rb
bundle config build.nokogiri --use-system-libraries
}
build() {
cd ${pkgname}
+ CFLAGS+=" -I/usr/include/libxml2"
bundle install -j"$(nproc)" --path vendor/bundle --without development test
}
@@ -49,13 +45,13 @@ package() {
install -d "${pkgdir}/usr/bin"
cat > "${pkgdir}/usr/bin/${_pkgname}" << EOF
#!/bin/sh
-BUNDLE_GEMFILE=/opt/${_pkgname}/Gemfile bundle exec ruby /opt/${_pkgname}/${_pkgname}.rb "\$@"
+BUNDLE_GEMFILE=/opt/wpscan/Gemfile bundle exec ruby /opt/wpscan/bin/wpscan "\$@"
EOF
chmod 755 "${pkgdir}/usr/bin/${_pkgname}"
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm 644 CHANGELOG.md DISCLAIMER.md README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- find "${pkgdir}" -name gem_make.out -delete
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ find "${pkgdir}" \( -name gem_make.out -or -name mkmf.log \) -delete
}
# vim: ts=2 sw=2 et: